Footprint editor: scale rotation and offset are blank and inoperative

I haven’t figured out the pattern to why. Sometimes when I’m trying to load a 3d model into a footprint, the 3d axis controls are blank, and typing values into them doesn’t make the model move. Sometimes it works just fine.

First you have to select the model name line above the view.

1 Like

Aha! That didn’t actually do it immediately, but when I unchecked and re-checked the Preview box at the end of that line, then the controls started working.

Seems like a bug, but it’s super easy to work around now that I know. Thank you!

You can have more than one model - for instance both a .step and a .wrl model or a number of different models of differing colours associated with one footprint. Each model can be scaled/rotated etc and activated independently. You need to select which model(s) you wish to move by selecting the correct line. If you have no line selected, then KiCad doesn’t know which model to adjust. Perhaps it could be more helpful in prompting "No model selected’.


Kicad 5.1.4: I thought that adding several 3D models to one footprint, making one only active by scaling to 0 the other ones was drastically increasing the time of the .kicad_pcb file processing. Is this confirmed ?

OTOH, there’s no option for loading a specific model or disabling the non-desired ones, except for viewing.
Scaling to 0 all the models but one is an option but not the best, especially in case of testing several models for better rendering.

What’s the opinion of the developpers ? Should this easily be improved in the future version ?

Go to and give a thumb up.

1 Like

TBH, I have only ever tried this with a couple of models for one or two parts on the board. I hadn’t experienced a slowdown but I would not be surprised if there was a problem if a single footprint is overloaded - especially if there were many instances of the footprint on the pcb. I agree, this could be better - I believe that the work in version 6 on ‘inheritance’ might go some way to improving this.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.