Footprint editor measure tool

Can the measure tool be unlinked from the grid, or alternatively can the grid resolution be changed? I have looked for ways to do either of these, but have failed.

Grid resolution can be changed from the toolbar on the top of the screen.

The “Measure Distance” tool can be started off-grid by holding both [Alt + Ctrl]

Thanks - now I see the grid resolution staring me n the face!

I tried Alt-Ctrl-M and Alt-Ctrl-Shift-M but neither of these started the tool at all.

  1. Select the measure tool.
  2. Move mouse to the drawing area.
  3. Zoom in (so grid points are far apart. (Possibly select a coarse grid first).
  4. Press [Ctrl + Alt] And keep them pressed!
  5. Mouse movements are now off-grid.
  6. Press left mouse button at an off-grid location to start the ruler there.

Been looking for this solution. However, I’m not sure what I’m doing wrong, but it doesn’t work for me. I’ll try again. Thanks.

Doesn’t work for me. The ruler still starts from the grid point nearest to the cursor, not at the cursor.

I can confirm that it doesn’t work in the footprint editor (in v5.1). Alt should turn off the grid but keeps the other snapping points defined in the Preferences. It works in the layout editor.

Here a little screencast that uses the “Measure Distance” tool in the Footprint Editor and I place the tool off-grid:

Note that I used [Ctrl +Alt]. Just [Alt] does not work on my linux box, probably because [Alt + Left_Mouse_Button] is assigned (by default) to moving windows, which means that combination is filtered by my OS and KiCad does not even see it.

Application: ModEdit
Version: 5.1.9-73d0e3b20d~88~ubuntu20.04.1, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3
Platform: Linux 5.4.0-58-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
    Boost: 1.71.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.68.0
    Compiler: GCC 9.3.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=ON
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

I ran into similar issues when trying to make a footprint… it was a bit frustrating to have the snap set to what I wanted it to be, but it was almost impossible to get more than 2-3 grid dots to display at a time. I would play with the zoom settings, etc., and sometimes I’d get a decent grid visible, but the very next operation would make the grid disappear once again. It made it difficult to properly measure and lay out the part for want of visual landmarks. I ended up having to register at yet another site to fetch the footprint I wanted.

Still doesn’t work for me. Ver 5.1.2-1 on Win 7

Any good reason for sticking to such an obsolete release?
5.1.9 is just out