Footprint Editor Appearance


#1

Hi,

It doesn’t look right, does it?

I suspect the acceleration option is to blame, but I can’t find a way to turn it off.


#2

What operating system are you using? What version of kicad?

There has been a report of something like this on the mailing list a while back.


#3

Arch Linux operating system, Kicad 5 rc2


#4

There is a problem with wx on arch. They switched to one compiled against gtk3:

More details see the original report on the mailing list: https://www.mail-archive.com/kicad-developers@lists.launchpad.net/msg28282.html

If you use nightly you should really consider following the mailing list and bug tracker more closely.
By the way there is no kicad 5 rc2 (yet) :wink: I think it is reported wrongly in the version string. (Every nightly after the rc1 tag is reported as rc2 for some reason.)


#5

Thanks! I use AUR version. Looked into comments - it should not be that bad. Again: is there a way to turn off acceleration? It’s obviously worth trying, no matter what.


#6

look in the view menu. (but i doubt this will fix it. It did not fix it for the original reporter.)


#7

There’s nothing suggestive of acceleration in the View menu, unfortunately.


#8

in pcb_new -> view there should be a canvas selection. If it is no longer in the view settings then it is in some other menu. It could be in the preferences or setup menu. (I hope they did not move it into some hidden dialog.)
You can also use a shortcut. (I think F12 is for the modern fallback mode. F11 is for modern accelerated and F9 is for the legacy canvas. The ? shortcut should bring up a list of available shortcuts.)


#9

It’s moved to the Preferences menu recently. You’ll want to switch from Modern (Accelerated) to Modern (Fallback). But I am fairly confident this won’t actually fix your problem, since the acceleration doesn’t have anything to do with the toolbars.


#10

Application: kicad
Version: (5.0.0-rc2-dev-45-ge3c71efbe), release build
Libraries:
wxWidgets 3.0.2
libcurl/7.52.1 OpenSSL/1.0.2l zlib/1.2.8 libidn2/0.16 libpsl/0.17.0 (+libidn2/0.16) libssh2/1.7.0 nghttp2/1.18.1 librtmp/2.3
Platform: Linux 4.9.0-6-amd64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
Boost: 1.62.0
Curl: 7.52.1
Compiler: GCC 6.3.0 with C++ ABI 1010
Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_ACTION_MENU=OFF
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_SPICE=ON


#11

The nightlies are tagged “5.0.0-rc2-dev” but that just means it’s the development branch for an eventual RC2.


#12

Strictly speaking they are not tagged. Only one commit can have a particular tag. (tag is a therm that comes from version control systems. It means giving a particular commit a user controlled name.)

If i understand the answers to my mailing list question correctly then the 5.0.0-rc2-dev stuff comes from some place other than git. I assume from the cmake file. (But it could also come from some other build file.)

It remains to be seen if there is a better way to communicate the fact that this is a nightly build from sometime between the 5.0.0-rc1 and 5.0.0-rc2 tags.


#13

It comes from the git describe command, which builds a string from the most recent tag (which is currently 5.0.0-rc2-dev) and then adds the number of commits since the tag and the short hash of the current git commit.

If it were tagged 5.0.0-pre-rc2-... would that be more clear?


#14

Either that or remove the hyphen between “rc2” and “dev”. I.e. tagged 5.0.0-rc2dev-...
The issue (for me) is after the “rc2” I didn’t understand what all the other stuff was (I just learned the phrase “git hash” reading the thread that Rene linked) so my mind ignored it as noise. Removing the hyphen would help move “dev” from the noise part. That said, now knowing it is not noise, maybe encouraging people to put the fully tagged revision from the “About” (add that question to the normal question about platform) would help…


#15

[quote=“SembazuruCDE, post:14, topic:9936, full:true”]maybe encouraging people to put the fully tagged revision from the “About” (add that question to the normal question about platform) would help…
[/quote]

Yes, that is the standard request/requirement for submitting things to the bug tracker, so it’s probably a good idea to make that a standard request here too when people are using prerelease / nightly builds.


#16

In the good old 4.07 you could switch in PCBnew between 3 different screen renderers:
[ F9 ] = Default Canvas.
[F11] = Open GL Canvas.
[F12] = Cairo Canvas.
Does anything change when you press those buttons?


#17

I’ve replaced wxpython with wxpython-gtk2. So far so good. We shall see…


#18

Yes, it blinks on F9, F11, and F12. All the three canvases look normal. The amount of destruction remains to be evaluated :slight_smile: .


#19

This definitely looks like the Python bug, not a hardware acceleration problem.


#20

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.