Footprint Editor 3D setting not sticking

I’m not sure if I’m misunderstanding the use of this feature but it is not working for me and never has:
When I have multiple STEP files to be merged as below, I assume I should be able to selectively turn them on and off and save the footprint in that state but, every time I reopen Footprint editor, KiCad has automatically re-selected all the disabled files. It even shows the STEP file without its checkbox being selected if I go back into the 3D properties before I exit footprint editor. See below.

It’s only for “preview” as it says. In 5.99, the unstable development version leading to v6, there’s a real “Show” option which does what you want.

Thanks eelik although I do not think that addresses the point. I can see the “Preview” but “Preview” of what? One would assume it is a preview of whatever is selected in the “3D Model(s)” box, which it sometimes does, but not always. Also, your response does not address why the 3D Model setting does not stick unless you mean to say the word “Preview” applies to the entire “3D Settings” tab. If that is the case then it does not make sense because that section is editable by adding and removing models. It is only the check boxes that get automatically selected even when you clear them and save the footprint.
Good to know that there is version that works different.:+1:

Preview is preview, there’s the preview view labeled “Preview” which shows the preview of the model(s). The tickboxes show/hide each 3D model in the list.

If one model is completely smaller than the other it won’t be shown because it’s inside the larger.

The model can be shown only if there is an actual file in the filesystem. See Why a footprint points to a 3D model but the model file doesn't exist? and https://gitlab.com/kicad/code/kicad/-/issues/3815.

It does make sense when you want to compare two models. Otherwise you should always delete and add paths again when doing comparison.

Thanks again. I’m aware of these points, they just don’t apply in this case.