Footprint does not match copy in library when 3D model is added


I noticed in Kicad 7 that if I add a 3d model to a library footprint that does not have one, I get the warning in the title. The two ways to avoid that are to copy the footprint to your own library or to silence the warning. Is this by design?

Seems a bit tedious when the original library footprint did not have a model to begin with.



I’m totally with you. This error/warning/info is too sensitive.

1 Like

Yes it is by design, because when you do an “update symbols from libraries” your edits will be wiped out. The warning is a prompt that you should copy the symbol into a personal library if you don’t want that to happen.

I don’t agree with that, but with crafyjon instead.
DRC is for verifying the integrity of the design, and especially when working with things like database libraries any deviation from the parts in the database must be flagged.

But I also understand that warnings like this are more of a nuisance to casual users of KiCad. I think that for a lot of “casual users” and “hobbyists” it’s better to simply disable that warning in PCB Editor / File / Board Setup / Design Rules / Violation Severity (or disable it from within the DRC by right clicking on a warning and selecting: Ignore all #### violations.) When you simply disable the warning instead of exporting the footprints to a custom library, you retain the links to the KiCad libraries, and this can be of use during refactoring of the project later, or when KiCad’s own libraries get updated.

Now I wonder whether it would be useful if a link to the original source of a footprint would be kept in each footprint even if it is exported to a project specific library…

I still think it is annoying, but now I have more context on why it is like that, and why other users might want this. Thanks!

IMHO, if the original footprint does not provide a 3d model and all we do is add one, that should not trigger a warning, as we are comparing “something” to “nothing”. It caught me by surprise because I had just run “Update footprints from library” (but with “Update/reset 3D models” unchecked). So I really thought the footprints themselves matched the library.

Anyway, maybe this thread helps others who are also surprised by this new rule.


your “something” can be updated back to “nothing” when you do an update, though. That’s the point.


Agreed, unless it is possible to get the 3D model added to the official library, and licencing usually prevents that, you have a local footprint that has not been saved properly to a personal library.
Now fast forward to after V8 comes out and you update this old project and the 3D model is gone.

Hi @craftyjon,

I stumbled across this today. Thanks for the explanation.

While I agree that it is something that should be checked it would be nice if Kicad would be more verbose in the warning. e.g. “different 3D model”.

The current “does not match copy” can literally be anything from moved pads (which is bad) to changed artwork/Silkscreen (may be ignored) or added/different 3D model (depends on usecase if bad or ignore).

This would it also make possible to “exclude this violation” depending on what is the trigger of the warning. Do ignore 3D model. Do not ignore other changes.

Why would it be bad, if there was no 3D model in the library but in the design there is?
I cannot imagine the use case where this would be a problem.
If the user adds a 3D model where the library did not have one I’d say the user knew what they wanted. I don’t see where this would affect the outcome of the PCB data for manufacturing.

Apparently in the upcoming v8 differences in the 3D model fields will be ignored.

1 Like

Decided to explore moving from KC6 to KC7. Ran into this problem for an existing design that passes DRC with no problems in KC6. However, even standard library parts like 0603 resistors and caps (which already had a 3D model and I didn’t touch) get flagged. I had hoped the transition would be easier than 5 to 6 was. I think I may wait for KC8 before moving.

I keep all “my” files, whether 3D’s or footprints or symbols in a directory under “My Documents” (I have windows 11).
This accomplishes two things:

  1. Keeps my files from being overwritten by Kicad Installs.
  2. My files get backed up with all the other “My Documents”

Just my mode of operating.

1 Like

And it is a very good mode of operating. :+1:

Trying to “Write” into a “Read Only” Library is problematic. :wink:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.