Footprint connections are lost

Hello, I’ve done a handful of projects in kicad, and never had this problem. When I designed my latest circuit in the layout editor, I built the schematic, assigned footprints to each component, made a netlist, opened PCBnew, loaded the correct netlist, and some of my connections aren’t there. And when I try to assign net names, certain ones aren’t available. Any advice? Thanks in advance.

I hereby certify that I am not simply asking someone else to design a footprint for me.

This is an auto-generated message that is in place on the “footprints” section of the forum. If I remove it and ask for a footprint to be designed anyway, I understand that I will be subject to forum members telling me to go design my own footprint or referring me to a 3rd party footprint site.

When I opened another project from a few weeks ago, and I assign footprints, I now get this warning:

“Some of the assigned footprints are legacy entries (are missing lib nicknames). Would you like CvPcb to attempt to convert them to the new required LIB_ID format? (If you answer no, then these assignments will be cleared out and you will have to re-assign these footprints yourself.)”

I’m not totally sure what this means. When I update PCB from schematic, I get warnings that saying that certain pads are not found in the footprints.

This is deprecaded, and has been so for several years:

Working with separate netlist files is intended for working with “external tools” and other “unusual” workflows.
The normal method is:

I’m not sure what is happening here. I assume you have an old project (How old, which KiCad version?) that has been opened in a newer version of KiCad (Which version do you use now?)

To further diagnose the problem, take one of the problematic footprints and examine it more closely. Is it a global, or a project specific library? Was that library made in an older KiCad version?

I think you can “upgrade” old (project specific) footprint libraries with Project Manager / Preferences / Manage Footprint Libraries / (Column) Plugin Type.

If that column is set to Legacy for any library, then you can choose KiCad from the drop down menu, and if it’s a project specific library (in a writable location), then I think this converts the library to a newer format.

I’m not sure if this works though. I think I did this once but I do not have such a project at hand and can not verify this right now.

I’m using kicad version 5.1.10 which is what I’ve been using to create all my files for the last 6 months when I first started using Kicad. This just suddenly happened the other day when I opened PCBnew.

I checked the footprint libraries and they all say “kicad”. I also tried removing the necessary global libraries and re-adding them, but have the same problem. All of the footprints make it over to PCBnew, but the white net lines aren’t there and it won’t let me manually select certain pads to create networks.

I do keep getting the warning that certain footprints are missing lib nicknames. Is there something I can do to remedy that? Thanks for the guidance.

The thread below has the same error message.
Maybe your solution is also similar.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.