Footprint assignment input field loses focus

After upgrading to 6.0.8 (from 6.0.7) the footprint assignment input field loses focus after every character. To reproduce:

  1. Run footprint assignment tool
  2. Select symbol
  3. Deselect “Filter footprint list by library”
  4. Enter e.g. 0603 in the text box

After entering the first “0”, the list is filtered, but the input field loses focus so the the remaining “603” is not entered. One has to click the input field with the mouse after every character.

Is this how it’s supposed to work or a bug?

Application: KiCad Schematic Editor

Version: 6.0.8+dfsg-1~bpo11+1, release build

	wxWidgets 3.0.5
	libcurl/7.74.0 OpenSSL/1.1.1n zlib/1.2.11 brotli/1.0.9 libidn2/2.3.0 libpsl/0.21.0 (+libidn2/2.3.0) libssh2/1.9.0 nghttp2/1.43.0 librtmp/2.3

Platform: Linux 5.10.0-18-amd64 x86_64, 64 bit, Little endian, wxGTK, lightdm-xsession, x11

Build Info:
	Date: Oct 12 2022 16:14:50
	wxWidgets: 3.0.5 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
	Boost: 1.74.0
	OCC: 7.5.1
	Curl: 7.74.0
	ngspice: 34
	Compiler: GCC 10.2.1 with C++ ABI 1014

Build settings:

Seems to work ok on win10.
There is a light delay (0.5 secs) after each key entry but it does recognise every key press.
Maybe this is a Linux bug?

I updated a 2nd machine (also Linux) and it’s the same behaviour.

This was fixed and the fix will be released in 6.0.9, see bug here: cvpcb text filter box loses focus when search results change (#12445) · Issues · KiCad / KiCad Source Code / kicad · GitLab

You can download a Windows testing build (6.0.8 + some commits) or build from source to try it out.

That bug seems be be the issue I’m seeing, indeed.

Yea, that’s the bug he’s seeing.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.