Footprint and model 90 degrees off


#1

Hi everyone,
I am new. I am doing an example project and got a very unexpected result when I viewed the board in 3D. I did redo the association with a different footprint and the same thing happened. Please see the screen shot below. Do I need to download a more recent copy of KiCad or did I do something to cause this pox? I am now on a Windows 10 PC.
Thanks
Tim Miner
PS I am about to click create topic and my screen shot is an HTML line of code…

Application: kicad
Version: 4.0.6 release build
wxWidgets: Version 3.0.2 (debug,wchar_t,compiler with C++ ABI 1010,GCC 6.3.0,wx containers,compatible with 2.8)
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Boost version: 1.60.0
Curl version: libcurl/7.52.1 OpenSSL/1.0.2k zlib/1.2.11 libssh2/1.8.0 nghttp2/1.19.0 librtmp/2.3
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=ON
USE_FP_LIB_TABLE=HARD_CODED_ON
BUILD_GITHUB_PLUGIN=ON


#2

The 3d models are not automatically updated. Sadly by default the footprints are.
This means that if we change something on the library side, your 3d and footprint libs will slowly get out of sync.

Solution for now: download the current 3d models directly from the repo.

Long term solution: disable the github plugin for footprints and switch to a local footprint setup.


#3

Hi Rene, Thank you for your input. It is in two parts, short and long term solutions… but, it seems (I know I don’t know for sure) that both statements are 2 parts of a short term solution. So, I am asking to clarify: If I “download the current 3d models directly from the repo”, don’t I have to “disable the github plugin for footprints and switch to a local footprint setup” to use the 3d models just downloaded? And, the bobc/kicad-doc is instructions for the first part, correct?
thanks
Tim Miner
PS I love your Cat profile picture. It reminds me of flying a helicopter.


#4

3d models can not use the github plugin. Only footprints can use it. (That’s the core of the problem. You still have the same 3d models you got with your installer but the footprints are from today.)

To use the 3d models you either need to copy them to the place where your current 3d models are located.
Or you need to point KISYS3DMOD to the location where you put your models. (Kicad main window->prefereces->configure paths)
You can also look at the current value of KISYS3DMOD to determine where your models are located.

Another option is to use the 3d shapes downloader. (pcb_new->preferences->3dshapes downloader)

But again if you do not setup local libs as described in the tutorial i linked in my prefious post it is just a temporary solution. (Installing local footprint libs gives you the control when you get new files.)