Flood not flooding pads with the same name on my footprint


#1

Hi all,

I created a footprint for a Torex Semiconductor XCL220 switching regulator and want the flood to connect to the power output pads but I have to manually fill it with traces to do so. I’m using solid fill, which seems to work for other devices.

I’m not sure if there is something wrong with my footprint or not.


#2

I assume that you are talking about a specific board in which you are using the footprint.

In which case, you would need to include the board file or at minimum a picture and a picture of your zone settings.


#3

I’m sorry. My board can be found at https://github.com/aaronw2/led-controller-wrover32.git

Right now I have a bunch of traces added to fill in the area. The part is on the right side near the middle.

I just opened it up and found it was set to thermal relief, but if I set it to solid it still won’t connect to pin 8 which I want to help with thermal relief.

I’m still fairly new to doing PCBs. This is the first one I’ve sent out to be manufactured.


#4

:slight_smile:

Here is your mistake:

You made it while you created the footprint.

And use the priority setting for a zone, so you don’t have to draw all those cut outs yourself - that’s what the CAD tool is there for.
Your big ground plane just needs to be a simple rectangle over the whole board and any additional smaller copper zones just need to be bumped up in their priority, so they fill BEFORE the ones with the lower priority number are being filled.


#5

Why did you make a normal rectangular pad a custom pad shape? Custom pads are meant for complex shapes that can not be represented any other way. (They have drawbacks. One of them is that you can not use thermals to connect to copper zones. Another is that they are more computationally expensive.)


#6

I changed pads 7 and 8 to regular rectangles and it still isn’t connecting when I flood. I pushed the change to Github.


#7

You will still need to check the pad zone connection properties as suggested by @Joan_Sparky

Also check the clearance and pad connect settings of your zone. (Zones have their own settings)


#8

I found the problem. It was using the parent properties for the pads and changing them to solid fixed it.


#9

I also just downloaded your project and the pad properties are still the same as shown by @Joan_Sparky. So it seems you have forgotten to push (last change was two days ago)


#10

They should all be updated. CL-2025-02.kicad_mod says it was updated 26 minutes ago. It looks like a nice part too. 1A 3.3v with only bypass caps needed. I updated my project as well.


#11

Now it it seems it is updated. (You pushed shortly after my comment)


#12

Thanks all for the help!