Flipped title window + frame [RTL vs LTR system]

hello all ,
i am new to kicad ,
i opened up a new schematic file and the title window + frame is flipped ,
also at the first look my schematic view is all black(not white) and only after i zoom in and
out this is fixed , evrey component that i enter the schematic is flipped also (even ready made examples)
i attached a picture

what can i do ?

Installed version? (>KiCAD main window> Help>Copy Version Information)
OS?

Try restarting your machine 1st.

PS: I can see 4.0.2-stable in that screenshot…

this is 4.0.2 stable,
this happens to me on both of my computer and restart wont solve it
add another pic :

OK. This only affects the drawing area, right?
Symbols in the toolbar, text in the menus, etc. are all correct?

Again, please copy the version information from KiCAD (>KiCAD main window> Help>Copy Version Information)

What happens in PCBnew?
Same thing?
What happens when in PCBnew and you go to >View>OpenGL Canvas?

Do you have a 3D GPU installed?
Does it have settings for flipping program content/screens/etc?

Application: kicad
Version: 4.0.2-stable release build
wxWidgets: Version 3.0.2 (debug,wchar_t,compiler with C++ ABI 1009,GCC 5.2.0,wx containers,compatible with 2.8)
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Boost version: 1.57.0
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=ON
USE_FP_LIB_TABLE=HARD_CODED_ON
BUILD_GITHUB_PLUGIN=ON

added the black screen on start(without zoom in and out)

You’re whole desktop is flipped. :confused:
The clock normally is on the right, same for the notification icons.
The taskbar/startmenu should be on the left…?!

What did you do to your windows?
Did you never notice that?
I’ve never seen one like this to be honest :scream:

Read this:


(sorry was wrong link, now correct)

Should do something along those lines:

I think you rotated you desktop screen 180 deg or flipped it 90 deg two times… :smile:
Anyhow, your clock should be at the top right and the start menu at the top left.
Opposite to what you have ti now.
If you want the taskbar down at the bottom of the screen drag it there (might need right clicking first to make it adjustable in some menu)

that is the hebrew version of windows ,
so all is on the left,
i didnt have any issues so far …
altium and eagle works just fine

1 Like

OK… that’s funny.
To me it looks like the screen is rotated 180 deg.
Didn’t know that you guys do everything backwards there… I thought you only had this for texts in books, but programs too?
That sounds crazy.

I live in Oz now (born & grown up in Germany) and besides that I now drive on the left hand side here (instead of the right) the screen still looks like in Europe with the same flow… top left to bottom right. :wink:

I would say they implemented the Hebrew version by rotating the screen with those key presses… any chance you can have a go at this and see if the screen can be rotated so the clock is at the top right?
Does KiCAD work then?
You definitely want to post your problem here (needs registering) and hope there is some easy and fast fix for this kind of special problem (if above doesn’t work):

And please mention that you sit in front of a Hebrew windows desktop that is a RTL system instead of the normal western LTR systems! :worried:

hi joan,
sorry about that didnt know it can cause any issues ,
i tried flipping my screen but all the keys flip with it ,
so it almost impossible to work like this ,
in pcbNEW on the normal view its seems the same but on the openGL Canvas view
it looks fine for a moment (i open the arduino example ) but if i try to move
i lose the image (i am a beginner so mybe i am doing it wrong)

Sorry to hear that.
Then off to the bug list with you, get registered and try to be as friendly as possible and describe that you got a hebrew desktop that is different and if they can do something about it.
My wisdom ends here unfortunately & developwers of KiCAD (there aren’t many) only very infrequently check these forums = your chances are highest with the bugtracker.
Good luck.

PS: I thought that for cases like this you guys would have some software that would enable stubborn software to run like in the LTS systems, but you would know that better than me anyway.

I don’t think you are doing anything wrong. It is most likely a kicad bug. Have you created a bug report?

The behaviour seems to be specific to Hebrew and Arabic:

this is a bug that I think was solved.
it is supposed to be related RTL langauges.
for me there is no problem with arabic.
here is the related bug