Flipped component pads do not change color

I hereby certify that I am not simply asking someone else to design a footprint for me.

This is an auto-generated message that is in place on the “footprints” section of the KiCad.info forum. If I remove it and ask for a footprint to be designed anyway, I understand that I will be subject to forum members telling me to go design my own footprint or referring me to a 3rd party footprint site.

Just installed v6.0.7;
When any component flipped to back of board, pads do not change to blue as expected. Noting that on the Board Setup dialog, F.Cu and B.Cu are the same orange color; this cannot be changed. Any help appreciated.

Strange, my B.Cu and F.Cu colours are green and red as has been for a long time. Can you not change it in the colour picker near the top right?

colour-picker

@jhoffnun
Board setup dialog does not change colors.
As @retiredfeline shows, Appearance - Layers change the layer colors. Hover mouse over the colored rectangle for instructions.
New color themes are created in Preferences / Preferences / PCB Editor / Color.

What color are they, same as top layer?

When a component is flipped, the pad color remains the top color (orange).

Hi,
Silly question maybe, but are you using through hole or surface mount footprints?

Another question. You just installed 6.0.7.
Are you using the default colors?
What colors are showing in the appearance manager for F.Cu, B.Cu & Pads?

Yes, using the default colors.
Appearance manager shows the default orange for top copper, and blue for bottom.

And surface mount or through hole pads?

Through hole pads. Happens with resistors, batteries, leds.

That is how it is supposed to be.

Surface mount footprints adopt the color of the layer on which they are placed.
Through hole footprints have a different color because they are always on the opposite side of the board to the components.

See above illustration.
Surface mount and Through hole footprints are on both top and bottom layers with some tracks.
F.Cu is default red.
B.Cu is default blue.
See the colors in Layers.
Through hole pads are default orange
Find them in the Objects list.

The white dots are “vias”. They connect the top layer tracks to the bottom layer tracks.

Edit: Note the rectangle enclosing each footprint. This is the “Courtyard” If the component is on the top layer, there is a Front Courtyard (magenta). If on the bottom layer there is a Bottom Courtyard (Cyan). Find these layers towards the bottom of the list in layers.

Interesting, I discovered that KiCad must have migrated my 5.1 settings, so I was getting green for B.Cu. Changing color_theme in pcbnew.json from user to _builtin_default made it blue like other people’s. Now I can easily see the difference between TH pads and B.Cu, orange and green didn’t look sufficiently different to me.

Now I’ll have to order blue PCBs to match. Just kidding.

And I was head scratching for a while as OP wrote about Board Setup, and, sure enough, Physical Stackup illustrates layers F.Cu & B.Cu both as orange. :thinking:

Aesthetically pleasing results for personal labors should be high on the priority list. :slightly_smiling_face:

Thanks so much for all the help.
Found the problem: was following the getting started in Kicad pdf, and chose a different battery footprint that had orange pads and thus could not be flipped to the bottom side. Paying attention to the pad color on the “View selected footprint” now makes this clear!

1 Like

Ahhh!!!

Now I understand all after reading through the “Getting Started”

Any other problems you have, by all means, please ask on this forum. Any confusion may also be avoided if you mention you are working through the “Getting Started in Kicad” manual.
Cheers, Jan.