Flatpak on Linux Mint Oopsie! Setup Worked Fine With V5 - Solved

Hello, I’m running Linux Mint 20.1 Cinnamon. I was using Kicad 5 for a long time until I tried upgrading. My system is really messed up now. How can I get back to V5?

Yes, I know Linux Mint is not supported, but it works fine with the Ubuntu install and V5. I want to upgrade this system shortly, but I’ve got a few projects I want to sort out first.

Hello @mlaflare

Mint is fine. I, and at least one other regular contributor, use 6.0.7 on Mint 20.1
What do you mean “messed up”?

Did you download and install 6.0.7 via the install manager?

1 Like

I clicked on LM on the download page and there was a warning that it isn’t supported. I downloaded Flatpak and installed 6.0.4 through it. I just tried updating it to KiCad 6.0.7 and it won’t let me… it says the current installed version is stable.

Examples load ok in Kicad 6.0.4, but it still seems broken. I get massive errors and it shuts down when trying to open any project from V5. I’m not comfortable starting a new project with it.

Have you looked in the Update Manager? 6.0.7 maybe there.

1 Like

It still says 6.0.4 in the About-> Help tab after trying everything.

I just want to load some old projects. It won’t let me load old project files. PCB files load OK in stand alone mode. Schematics give me an error in stand alone mode. When trying to load, I get a warning flash “The project symbol library cache file was not found.” I tried pointing to it and no luck. I tried putting it in a temp directory and no luck. Setting up library paths always messed me up in V5. Without the library, I get question marks everywhere. Here’s the kicker… If I browse symbol libraries, I can see all of my stuff and manually load every symbol…

Are versions 5 and 6 not friendly with each other? Should I install V5 next to V6?

You can open anything in 5 with 6 but not anything saved in 6 with 5. The Schematic has had major changes.

Mint is not officially supported, it is not unsupported.

Have you tried to download using:

sudo add-apt-repository --yes ppa:kicad/kicad-6.0-releases
sudo apt update
sudo apt install --install-recommends kicad

with your Terminal?

I just ran:

sudo apt-get upgrade

ppa has nothing to do with my Flatpak install. That’s a totally different package.

But it works properly.

Maybe there was a problem with your 6.0.4 installation. 6.0.4 did work. 6.0.7 is just additional bug fixes of 6.0.4

1 Like

Hahaha the Ubuntu package works now!! It wouldn’t before.

Thanks everyone!

1 Like

Which package works now?
What did you do?

It would be great for future reference to know what has happened. :slightly_smiling_face:

I uninstalled the Flatpak install and installed 6.0.7 Ubuntu KiCad PPA referenced above. I haven’t found any issues yet and my old projects load just fine.

1 Like

Great!!!
Thanks for the reply.

You will now find any updates will appear in your Update Manager… eg 6.0.8 when it exists.

Note: 6.99 (the future 7), is broken in Ubuntu at the moment, so don’t bother trying to experiment with it.

Note the changes in the Schematic.
After saving a 5 project in 6, that project will not open properly again in 5, so it is worth keeping backups in 5 at least 'till you’re happy and confident with 6.