Flatpak Icons in Menus

KiCad 6.0.0, installed and run via flatpak, does not have icons in menus regardless of GTK theme and Preferences setting. I also installed Gimp via flatpak to see if correctly has icons in menus, and it does. Is there an additional setting somewhere I’m missing?

Version info
Application: KiCad

Version: 6.0.0, release build

Libraries:
	wxWidgets 3.1.5
	libcurl/7.79.1-DEV GnuTLS/3.7.2 zlib/1.2.11 libidn2/2.3.1 nghttp2/1.44.0

Platform: Linux 5.13.19-2-MANJARO x86_64, 64 bit, Little endian, wxGTK, KDE, x11

Build Info:
	Date: Jan  6 2022 19:34:22
	wxWidgets: 3.1.5 (wchar_t,wx containers) GTK+ 3.24
	Boost: 1.78.0
	OCC: 7.5.1
	Curl: 7.79.1-DEV
	ngspice: 35
	Compiler: GCC 11.2.0 with C++ ABI 1016

Build settings:
	KICAD_USE_OCC=ON
	KICAD_USE_EGL=ON
	KICAD_SPICE=ON

Do you have the menu icons enabled in your desktop environment settings? We rely on GTK to show the icons, and sometimes the desktop environment will hide them. On MATE (the one I use), I can find that setting in the appearances preferences window under the interface tab.

Yes, I should I add that menu icons are present when KiCad 6 is installed via my package manager.