First-time User Cannot Open New Project

Hi. Sorry for apparently not having the chops needed to use the latest Kicad version for Windows 10 x64. Opening a new project hangs the system when the schematic editor tries to start and no error messages are generated.I see mentioned that there is a known problem with the Boost libraries using Windows 10 x64. Is there no way to download a working version that includes the right Boost libraries? I also tried the x32 version with the same results. I just want to create schematics (for now) and don’t know how to go about finding the correct Boost libraries, if that is the problem, nor what to do with them even if I find them.

Please tell us more about the install. Did you use the standard download or are you compiling from source?
It’s preferable to state the version rather than “latest”.

I’d suggest uninstalling what you have and download 5.1.5 or 5.1.6

Hi Barry,

I am using the standard download on the KiCad-pcb.org website for Windows 64 bit - 5.1.5_3-x86_64. I didn’t “Run as Administrator” when installing, as I read somewhere to avoid doing so. I used the default selections when asked to choose components to install. Once installed, I chose Create New Project. The system notified me that on this first project I needed to set up libraries. I chose to “copy the default global system library table (recommended).” Now, when I attempt to open the schematic editor the system hangs. I have to kill the app using Windows Task Manager.

The Known-System-Related-Issues page in the Help section provides the following information for the Windows OS version:

Boost 1.59

On 64-bit Windows, KiCad’s usage of the boost context library is currently broken due to changes in the library. This causes pcbnew to crash on start. The only workaround is to use boost 1.56 or 1.57 which are known to work.

My initial post asked why a version of Boost that is known to work isn’t included with the latest installer for Windows x64 (at least until the library issues are resolved). This notice has been posted for several months.

I am running Windows 10 Home V-1903. I have also tried the x32 version. The results are the same, so my issue may have nothing to do with x64/Boost compatibility.

I greatly appreciate your help.

I am not sure where did you read about the boost libraries, but the problem that you are having seems to be more related to graphic card drivers and the canvas type (modern or legacy).

Whenever you have an issue it helps to copy the full version information and post it here help>about kicad>copy to clipboard

Glad you could solve your problem.

P.s. Remember, this is a user forum where other users like you help each other, developers hang around but it is no guarantee.

I don’t know what is boost.
I have installed the same file as you (few months ago) at Windows 7 64 bit and used it without any problem (except bugs present in 5.1.5).
In the KiCad documentations (at the time of 4.0.6 version) I have read about Windows don’t like when programs try to edit anything in Program Files directory and KiCad had there the default project and in documentation was written to setup a list of libraries and save it to that project.
Because of this (I read all documentations before first installation) I have never tried to install KiCad in default directory. I just created in C: my own directory ‘Programy’ and always install KiCad (and some others) there.
I don’t know if this is your problem source but I think - can be.
I don’t know the note about installing as not administrator but isn’t it that you then have no full rights and may be Windows know better what you should do and what not.

The other what happaned to me was that when I installed KiCad at one PC it worked and at the other (not connected to internet) it didn’t worked. The reason was the installation file was corrupted during copying to that second PC (I have never else noticed any corruption of files during copying through pen-drive). I’m not sure if installer worked and program not or if installed didn’t worked. But as I had some problem to find it I think (not sure) installation looked as done correctly.

Thank you Piotr,

I tried reinstalling in a different directory as you suggested, but it still didn’t work. The only way I can get the schematic editor to run is to use someone else’s eeschma file (offered up in one of the posts); for whatever reason the system hangs up before it creates one in my situation.

I am not doing anything fancy, just trying to install and run the system for the first time. There is most surely a bug in the code. I’ve seen more than one post of people complaining about 5.1-3 on Windows.

I suspect most people don’t see it because they aren’t starting from scratch as a new user. If someone were to do a clean install on a machine with no kicad files anywhere on their system including in the username/appdata/roaming/kicad directory, they would run into the same problem. I also bet it escapes testing because usually, developers run regression tests using complex user datafiles instead of having no existing datafiles (as with a new clean install).

I can make it work, but it’s not right. I get weird library error files and it may be due to my using this borrowed eeschema file. I may just wait a few months to see if the problem is eventually fixed.

I appreciate your taking the time to respond to my post. Thank you very much.

I install KiCad at one PC as clear instalation (after removing the previous and deleting appdata… kicad directory) and at the second as not clear.
I don’t use that clear instalation frequently - only when searching for footprint to copy to my libraries or to check something before reporting a bug. I didn’t noticed the problem. But to be honest I’m not sure if I tried to run sch of 5.1.5-3.

Because of some bugs in 5.1.5 about a month ago I moved to pre 5.1.6.
Just try it. If there are still the problem you should report it, I think.

There is some great information in the post “Program Freezes – virtual VM Hyper V” where I found that others are apparently experiencing the same problem I am seeing, (which it turns out has nothing to do with virtual machine implementations). An issue report was linked to this post “v5.1.5 Eeschema crashes on first opening after installation (IP# 1854593).” So there is a bug and the fix is scheduled to be released in v5.1.6. The issue is only related to the schematic editor not opening; apparently everything else works just fine.

The root of the problem has to do with graphics hardware acceleration. That feature does not work on my machine, so the software typically falls back to software rendering. The eeschema configuration file tells whether to use hardware acceleration. When starting from scratch, the eeschema file has not yet been created, so the schematic editor creates one. However, it does not first check to see if calls to your graphics driver works, it only assumes you will use hardware acceleration. The result is the system hangs up. By the way thank you again, der.ule (Ulisis), if you are reading this, for putting this information in front of me.

There is a workaround, which is to create the eeschema file manually in your user settings folder and include nothing but the line “canvas_type=2”, which must effectively must mean “use software rendering”. I’ve tried it and everything seems to work. I will also try pre 5.1.6.

I look forward to learning this system and collaborating with you all.

2 Likes

Another thing you can try is to open Eeschema from a command window, instead of clicking in a menu.

If it’s started from a command window (terminal) it often spits out some debug info when it crashes.