Filtered footprints in device library stopped working in Windows 10

My device library suddenly stopped showing default footprints. Any idea how to get them back?

The footprints show up in the footprint library browser…

Update 1: After restarting my PC, it shows up again. However. If I then start the board editor, it breaks.

Your Symbol Device Library should not show footprints for generic symbols. Note this edit originally omitted because I assumed the topic was regarding the R the OP posted.

Often, any number of different footprints can be assigned to a symbol.

Maybe you had assigned a footprint to a symbol in a project. If that is the case, then every time you copy that symbol in a project, that symbol will have the same footprint.

That is not true. The footprint preview in the symbol selection works normally.
However, not all schematic symbols have a footprint attached by default. There can be many different footprints for a humble resistor. Both SMT and THT, and from very tiny to big power resistors. For the generic symbols, KiCad does not have any default footprint, and this forces you to always assign a footprint to it.

For reference, this is the same thing on my linux box. You can see all the default footprints there. It worked before on windows, but suddenly stopped.

your memory is playing tricks with you. The default resistor symbol from the device library has never had a default footprint.

Sorry, I didn’t know you were using Windows. I can’t help. I run Linux only.

What is your Windows version?
I will edit your thread title to attract some windows users.

Please see my edit on my first post.

The OP seems to be writing that he can no longer show the list of footprints available for that symbol using his windows version of Kicad.

Oops, that is a detail I missed. But somehow I doubt it is windows related. I think the list is generated depending on the “keywords” section of the symbol. You can load it in the symbol editor and then: "Symbol Editor / File / Symbol Properties**

But it’s a symbol from the default libraries, so it’s unlikely it shows up any different on your system.

Windows 10. Gonna see if I can reproduce the issue on my linux box. The breakage happens when I open the PCB editor.

I installed Kicad 6 to try and reproduce it. And now I can’t reproduce it in 7.0 again. I’ve no idea what happened. Reinstalling 7 didn’t work, but apparently installing 6 made 7 work.

This thread title is wrong. Default footprints are one to one for symbols and don’t get used with the generic symbols in “Device”
The OP is referring to filtered footprints

Edited thread title again.

Under Windows 10, I tried 7.0.9 release and latest Nightly 7.99.
Both offer footprints filtered exactly as I would expect for generic symbol “R”

The issue returned today. It seems to happen intermittently. Sometimes it fixes itself when I restart, but other times not. Is there a way to get debug info from kicad?

Which kicad version do you use exactly?

Hi @Jasdoge

Find and post your exact version by opening Kicad, then Help > About Kicad > top RH corner click “Copy Version Info” then Right click > Paste directly into a post you open in this forum.

Application: KiCad x64 on x64

Version: 7.0.9, release build

wxWidgets 3.2.3
FreeType 2.12.1
HarfBuzz 8.2.1
FontConfig 2.14.2
libcurl/8.4.0-DEV Schannel zlib/1.3

Platform: Windows 10 (build 19045), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Nov 5 2023 19:26:40
wxWidgets: 3.2.3 (wchar_t,wx containers)
Boost: 1.83.0
OCC: 7.7.1
Curl: 8.4.0-DEV
ngspice: 41
Compiler: Visual C++ 1936 without C++ ABI

Build settings:

1 Like

ok, with v7.0.9 the issue linked by @RaptorUK is resolved, so this is something else. Sadly I can’t reproduce it (windows10), so we have to wait for other confirmations or you have to open a gitlab issue yourself.