Filter list keywords in Cvpcb ( - vs _ )

I was working on the Getting to Blinky tutorial and when i went to associate my components to footprints, they mostly worked, except for the LED’s i was only getting choices of LED-3MM, LED-5MM, and LED-10MM . No SMD devices. I searched around and found that if i changed to “filter by library” (third of the filter choice icons at the top), i could get the right devices LED_0805 or LED_1206. So then i tried to figure out why the keywords search wasn’t working . . .

At the bottom status line, i see that the “filter list” on the very bottom of the window shows Cvpcb is searching several keywords including “LED-3MM” “LED-5MM”. It was also searching for “LED-0805” “LED-1206” but NOT searching for “LED_0805” or “LED_1206” Note that is was searching for the "-" (dash) and not "_" (underscore). The Github libs all seem to use the "_" and not the "-".

So now I found out the why, i’d like to figure out how to fix the problem. I tried editing the .net file by hand to change the "-" to a "_", but that didn’t work - i still had the same “filter list” show at the bottom. I poked around, but can’t figure out where to the change the keywords. I looked at the component in the Library Editor, and found only the keyword “LED”. Yes, i could filter by lib, but it’d be nice if this could get fixed so the right keywords were generated. Any help would be appreciated.

Thanks in advance . . .

1 Like

In the Symbol Editor, look at Properties then Footprint Filter.

Although in my version the footprints use hyphen rather than underscore.

ETA: seems this PR broke it

ETA2: I would recommend raising it on the kicad-library While there is no guarantee it will get fixed, there is a better chance someone will act on it


That was it. I Added LED_0603, LED_0805, and LED_1206, and now the filtering on Cvpcb works right off.

I will take your recommendation and bring it up on github. I appreciate your help to a kicad (and github) newbie.