Filter by number of pins broken

For the last couple of months I have noticed that the filter by number of pins feature in Cvpcb seems to be broken as no results are displayed when it is selected. I have tried both manually downloaded libraries and letting it use live versions from Github. I had a quick look on the launchpad bug list and nothing has been filed as far as I can tell so I was wondering if anyone else is having the same issue or if I should file a bug report.


  • KiCad is being built from source
  • Problem exists in versions from tonight and about a month ago
  • I have tried it on multiple machines, although with the same software setup
  • Im running Fedora 27 and while I know a nightlies repo exists they sometimes have other weird issues and automatic update downloads are problematic when it downloads >1G every day when I open my computer

Which symbols did you test? Do other filters result in what you expect? Does the same happen in an official nightly (meaning a packaged version)

Interestingly, filter by pins does work on my laptop which is also built from source
kicad version 5.0.0-rc2-dev-45-ge3c71efbe
Symbol commit #595fce23456cf8197c4b9a4a1d875669e409beaf

It is also working with the latest COPR version
COPR version on fresh fedora 27 VM:
5.0.0-rc2-dev-unknown-r12485-79fe1344, debug build
built in symbols and footprints

Ill have to get the specific version numbers on my other computer when I get home, although this is starting to look like it may be a configuration issue with my machine

As far as symbols tested, I did a few basic components and a custom one I made

  • resistor (2 pins)
  • pin header (2,5,8,10 pins)
  • custom part (33 pins)

On my desktop where it is not working, keywords, library and search work exactly as expected.

I’ve an issue too.
I’m testing with simple lm2901 (14 pins) and lm2904 (8 pins).
If I select the pin number filter, I’ve the wrong result, it give me a 20 pins soic for the lm2901 and a 10 pins soic for the lm2904.
It seems to count every power pins on symbols need to be added…

I’m working on kicad 5 build on debian 9 and I’ve download libraries last week.

This is besides the fact but the symbol should not have the power pins double. That is clearly a mistake in the lib. (They should be on a separate power unit instead.)



Thanks for the reply.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.