Filled Zones, change clearance in specific area


#1

I cannot find any option for this.

I tried to place a second filled zone with a higher priority within the bigger one and changed the clearance-setting there.
Works, but all the pads from the “inner” Zone are no longer connected to the surrounding zone (despite appearing to be connected visually, but DRC tells otherwise).

Any suggestions?

Version: 4.0.3


#2

To make DRC happy a track from pads (same net) in the different zones should suffice.

Check the gerbers very carefully where one zone ends and the other starts. Especially at the resulting outer edges. I remember that when one chooses rounded corners there were some ugly artifacts left at those transitions.


#3

That workaround is a bit dirty though. I have to lay tracks to a pad of the other zone. Otherwise DRC still complains.

You are right, there are also artifacts at the outer edges, despite having “Corner smoothing” set to “None”. In fact, changing this option does not change anything at all (yes i press “b” everytime). The outer corners just stay rounded.

I’ll scan the gerber files for inconsistency.