Filled Zones: better control of the shape

Working with filled zones, I’d like to see better control of the shape.
1. Why, when I move a corner, it isn’t snapping on the grid points? (working)
2. When I move a corner, I’d like to use a modifier key to restrict the movement to 90 degrees relative to the other points.
3. I’d like to see an entry in the contextual menu: “Make shape rectangular”.

There is a workaround to make straight rectangular filled zones: make a rectangle and then convert it to a filled zone.

There is this tickbox in the zone properties window:
grafik
This is sort of doing what I want, but the behaviour is buggy.
It only works when selected when the properties dialog opens up for the first time. If the setting is adjusted after the creation of a filled zone, this property will be ignored.

the tickbox in the image:
Yes, it’s buggy. And in the development-version this tickbox is already removed. So better ignore it.

The only workaround to make straight rectangular filled zones is to make a rectangle and then convert it to a filled zone.

Use the “Shift+Space”-hotkey to enable the “restrict to H/V/45°”-drawing-mode. This makes drawing rectangular zones much easier.
Look also at the statusbar, on the very right side: there is than a message “constrain to H, V, 45” displayed.

1 Like

Wouldn’t it make sense to let the corner points also snap to the grid when grid snapping is enabled?

You must have some other KiCad than I :slight_smile:

Do other things snap to the grid?

You can influence grid snapping behavior with: PCB Editor / Preferences / Preferences / PCB Editor / Display Options / Grid Options / Snap to Grid, but this behavior should act the same for all objects. I have no trouble for snapping corners of zones to the grid.

Other things snap to grid.
grafik

EDIT: Guess that grid is too fine.

Well, that would be about 10seconds of work to check on your side, but guesswork and speculation from this side.

1 Like

Too fine it is. Snapping is working.