Fill Zone Problems


#1

If I try to place a fill zone down under any net other than , the fill zone doesn’t fill and shows on the screen as if it was a fill keepout zone. Any solutions?


#2

Are you set to show a filled zone? I think about the 8th button down on the left side sets the fill to ‘show’. Next one is outline mode so you can see what is going on.


#3

Unfortunately, yes. It is enabled for viewing filled zones.


#4

OK. Let’s try and understand your original question a little better.

Other than what? Have you set zone priorities? If zones overlap and have the same priority they become a jumble.


#5

Oh, haha sorry about that, I tried using less than and greater than operators – it picked up as formatted text and deleted it. So if I were to create a new copper fill, it will work just fine if i assign it to “no net”, but any other net wont work. I’ll attach an image of the difference between using no net and the 3v3 net.


#6

I think this came up recently. You have to have a component of that net inside the zone.


#7

Unless I’m doing something horribly wrong, that doesn’t work either.
The picture is a component with GND on a GND fill.


#8

My last guess/suggestion before going to bed. Back when I was using V4 I’d have this problem on occasion. Deleting the zone and redrawing it always worked. You might try restarting the program. Good luck. Hopefully knowledgeable people will show up soon. :wink:


#9

Restarting didn’t do anything, redrawing didn’t either… I’ll try reinstalling KiCad. :confused: Thanks for your help btw!


#10

In PcbNew, in the left hand vertical menu bar, item 8 from the top, ensure that “Show filled areas in zones” is selected.

Also, depress the “b” key to rebuild the zone.


#11

A filled zone (with a net) must be connected to a pad (of the same net) for it to fill. This means either the center point of a pad must be inside the zone or you need to connect it using traces and or vias to a pad.
This is to avoid orphaned zones.

More details: Filled Copper Zones not showing up in Gerbers/Printouts/3D view

Your last screenshot does not look like it has this problem (at first glance). For that case ensure you have selected one of the nets present in the pads of the footprint you placed. Also make sure you redraw the zones.
Additional problems can arise from the clearance and thermal spoke settings. Try to set the zone to connection solid or draw a short trace from the pin into the zone.