Fat Trace Extends Past Pad Outline

I have an LED with small pads, routing 2.0mm traces to them due to 1A of current flowing.

Issue: The 2.0mm traces connect to the pads but overflow the pad towards the center pad. Due to manual mounting of these LEDs, even though there will be soldermask on top, I’d prefer to stop copper trace at the edge of the pad.


  1. Is there a way to prevent the trace from drawing past the pad’s boundaries?
  2. Does KiCAD v5.1.10 have a fillet feature so that the pad to trace connection is blended with copper and doesn’t have 90 degree corners or is that only in v5.99 nightly?

I am a fellow aficionado of wide traces, although 2 mm is probably more than you really need for 1A.

Are you at liberty to modify the LED footprint? I am thinking of adding 1 additional 2 mm wide rectangular pad1 to pad1, and similar to pad2. This rectangle would replace the LED connecting end of the 2 mm trace. One disadvantage is that the added pads would normally not be covered with solder mask.

Another way would be to add small rectangular zones, but I think that the traces would normally try to connect to the pads and not snap to the zones.

I could modify the footprint, but I won’t because the LED is SMD with hidden pads, so having pads that are larger would be detrimental to soldering and positional accuracy.

I thought about zones, would be a little work but I suppose I could route 2mm to the zone and then route 0.5mm or 0.2mm to the pad connection, to satisfy DRC, since connection to zone doesn’t satisfy DRC.

I thought maybe there was an easier way.

Changed design to this:

That’s not an issue. You can remove the mask layer from the extra pad.

The ends of track segments in KiCad are always round. I have never seen any other shape for a track segment.

Adding triangular zones such as you did in the 4th post is a valid solution.

If you have a lot of these LED’s however, drawing or copying all those zones for those LED’s becomes a bit tedious. In such cases, a better solution is to use extra pads in the footprint, or make a complex pad (which is a combnation of a normal pad and custom graphics). If you do this, then use overlapping pads, and give the pads that overlap the same pad number.

You can also control the settings for each of the pads in the footprint editor. One posibility is to use normal (or complex) pad for the copper layer (Disable the solder mask and solder paste layer), and use a completely separate pad to define the geometry for the solder mask and paste layers. These are called “aperture pads” and they have no pin number at all. Leave the pin number blank in these pads.

as workaround you may have a look at taper footprints

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.