Failing to add FP library?

Hi together,

have been using KiCad 5 for quite some time, now started using KiCad 6.0.6.
Quite confident so far, there is just one thing, that drives me nuts, since it doesn’t seem to work.
How to add a new or existing footprint library ??

For existing I go to the footprint editor, go Preferences>Manage Footprint Libraries.
Use the small folder icon down below, to add a new line on global tab, in standard kicad_mod format.
Works so far, line and path comes up, tick for ‘active’ is there.
→ Doesn’t show up on the library tree.

Even when I do File>New Library and follow the assistant, it will also be in the list under Manage Footprint Libraries, but it will not show up on the library tree.

What am I missing here ??
I am basically stuck not being able to create footprints, since all existing standard libraries are read-only.

Thanks a lot! :slight_smile:

For me: Footprint Editor / File / New Library / Project / [OK] and filling in a file name “just works”. Although the name easily gets lost in the long list of pre-existing libraries.

Hello and welcome @nEmai

For a new footprint library you start with the Footprint Editor then:
File> New Library > Global>
Next give it a name and a location (select from list of places on Left column).

You will see highlighted in green where the name of the library is needed and, in my case, a folder in D drive is where I will place the new library.

Seeing you have just started 6, it is probably worth creating folders with your Operating System into which you may place your personal libraries. This just aids housekeeping and makes backups easier.

Hello paulvdh,

Thanks for your reply.
I think I am getting to the core problem here now. :slight_smile:

Did the same, what you supposed, with a project library. New lib ki6_project inserted.
[see pictures below]
Did the same steps for ki6_global, making it a global library:
[see pictures below]
The entries for the paths seem okay, from what I can tell from my experience.

This is the result:

I did not try ‘project’ before.
So while adding project-type libraries seems to work, global-type doesn’t seem to work.
I am at least able to work now let’s say, but I don’t want to organize my libraries project-wise.
And also I would like to not have to add them for every project again as a project-type.

Whats the problem with global here?

Thanks! :slight_smile:

Sorry, reread your post. I missed the above comment.
Preferences>Manage footprint libraries>Global, then
Click the + symbol to add a new line
Click the empty rectangle in the Library Path column
Click the little black folder that now appears in that rectangle
Navigate to your library you wish to add
Give it a nickname. NOTE the nickname will determine where the library is situated in the Footprint Browser Global List. If you wish it to be at the top of the list, prefix the nickname with a number less than 4.

Hello jmk,
thanks for your input, You can see my entries in my post above.
I guess they should be fine.

I also checked the bottom of the library tree, since Kicad5 had the habit of not sorting the tree alphabetically, but put new stuff in bottom :smiley:

Personal libraries are always at the bottom of the list in the Global Libraries list, but the nickname determines where they are in the Footprint Library Browser when the PCB editor is open.

Oh okay, didn’t know that one. Good to know.

But yeah the problem remains, that my global libraries ki6_lib and ki6_global are nowhere to be found, whereas ki6_project just works as intended. :thinking:

Do you know where they are in your OS?
Did you follow this:

Re-reading your work flow, I think you were clicking the black folder beside the + sign. That folder icon is not the one you require.

Concerning where the files are: The folders sit right to each other.
If interested in path, you can see it in my screenshots above.
And in fact these are currently empty folders, waiting for footprints to be created.

I feel the folder icon below the list and your workflow are supposed to be the same, but to be dead sure, I step-wise recreated what you have written. It doesn’t work for global, whatever I try. They just will not show up.

This is the result after using the + below the list. I guess the result is quite the same as what I had above:

Clicking this folder icon after this + sign and you still don’t get it showing?
Your nickname starts with a “k” so it should show after"jumper" in the PCB editor Global Footprint Browser List.

I do not understand why a project specific added library is visible while a global library is not.

Just to exclude there is something weird with the path names, can you create such a global library in a completely different and simple path?

Haha yes, I did exactly this, really :wink:

Regarding ‘+’ or ‘black folder’ i just tested it on the project libraries tab.
I could add a library either way and it would show up without any issues.

But both ways don’t work on global tab for me.

Good approach. I created a new folder in the default directory for footprint libraries.

Also doesn’t work.

One image rule sucks a little.

Folder view:

Does this mean you found the library?