Failed to load symbol library expecting '(' in .lib file line 1, offset 1


I am working on a project in kicad nightly build, adding new symbol in Schematic editor cause the error in specified in subject.

PLB the screenshot for that.

Although I have added nearly 30 library before that but not cause error, suddenly it started to give above error.

Please suggest solution.

Version: (5.99.0-9949-gc5c348538e), release build


If you use nightly builds (5.99), please keep it up to date. Bugfixes come in every day. Your version is 2 months old.

5.99 doesn’t use the old .lib file format, it has switched to .kicad_sym s-expression format. Old libraries should be converted before using.

And how can I convert the same to .kicad_sym s-expression format?

Go to Preferences -> Manage Symbol Libraries. There’s a “Migrate Libraries” button. I haven’t had a need for that, so you have to experiment or ask someone else for details if there are further problems.

Thanks a lot, it works.

There is another option besides migrating the libraries to v6 format, which keeps them in the legacy format but is read-only. @eelik’s suggestion is probably what you want, but for completeness I’ll explain this one too :slight_smile:

In the “Symbol Libraries” dialog, there is a “Plugin Type” column. Choosing “Kicad” will interpret them as v6, which will cause warnings if they’re actually v5 format. Choosing “Legacy” will read them as v5, which will cause warnings if they’re actually v6 format. Legacy libraries are read-only in v6/5.99.

1 Like

@gkeeth Thanks for reply. I got your point.
I have one more confusion, by the above method all already added library started to works fine.
Now when I added a new library which I downloaded from “snapeda” what should I do ?

I added them as usual and plugin type in kicad selected and then click ok, but that gives error specified in subject, any idea what to do ?


See the latter half of this post: [SOLVED] How to contribute to KiCad symbol library?, it should work for snapeda single symbol libraries.

This just works as expected. No problems, no hassles.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.