F Mask plot crashing Pcbnew

Hi all,

I am trying to generate GERBER files and all but F Mask seems to crash my Pcbnew. All the other files generate fine.

This is the first time I have encountered the problem and not sure what to do. I am using the new version of KiCad 5.1.8

Thanks in advance,

I have resolved the issue with KiCad 5.1.6 . This must be an issue from 5.1.8


This does not look like a “crash”, just a warning that you’re doing something unusual.

If you want to set it back to it’s default, then look at:
Pcbnew / File / Board Setup / Design Rules / Solder Mask/Paste

Oops, I overlooked the “Plot (Ne Respond Pas)” part the first time.

It looks like the dialog window “does not respond”, so technically this isn’t a crash, it hangs or freezes (https://www.cyberlink.com/support/faq-content.do?id=14592 ).

1 Like

No problem yes sorry for the french. Thanks for trying.

I have reported previously that after 5.1.6 there was a change to the soldermask genearing engine that in some cases caused massive wait times to complete soldermask (if not set to 0).
Leave it running for few minutes, and see if it actually works. It worked for me, though.

1 Like

Yes, it probably is.

So I have left it for 5 minutes around and it still not responding. I have perfomed a rollback to 5.1.6 until this is resolved.

Okay so after 12 minutes it is complete. This is seriously a long time compared to the last time.

I’ve tried to isolate the root cause of the lagging, but I failed - after simplyfying the board the generation was progressively quicker so no obvious case.
Maybe you can share a design which triggers the issue so it could be added to the bug report for investigation.

How would I share it? Can I attach it here? Good for future developement.

Thanks for trying Fred.

There’s an Upload button here, you can send files from your harddrive to the forum.

Here I have uploaded the project in concern. This should be of interest and help the community with bugs.ING401_B_backup.kicad_pcb (1.4 MB)

Thanks for the upload, just reporeted the issue on Gitlab:

Pleasure to help :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.