F.Fab and B.Fab layers don't hide when unchecked

Hello all…

Text on the fabrication layer isn’t hiding when it’s the layer is unchecked. Drawings do, but not the text. It’s making the interface very difficult to work with.

I just upgraded from 4.0.0_RC1 to 4.0.1 Stable to try to fix it, but it didn’t work.

Ok… clearly, I’m baffled. I unchecked ALL layers, and now the fab layers hide. But an unneeded bit of reference designator that I marked as “Invisible” on the B.SilkS layer won’t go away.

Oh… wait. So, it doesn’t hide when checked in “Default”, but does hide when checked in Open-GL.

And when I mark a component’s reference designator as “Invisible” it appears and won’t go away, but when I mark it as “Visible” and then uncheck the silk layer, it does go away.

What. The. Hell.

That’s the case since 6097 for me on windows 7… :smile:

Have you tried with OpenGL view ?
There are differences in the dispaly with OpenGL and legacy (default) viewer.
IMHO, legacy viewer does not behave as expected for component References and Values.