F.Cu Differences in Footprint vs Layout for BGA pads


#1

Hi everyone,

I’m running into some confusion about the F.Cu layer for BGA pads. When working with the LBGA-169 footprint, the F.Cu layer seems to indicate that pads are overlapping.

The representation of the pad in the footprint editor is what I expect.

However, when placing a footprint in Pcbnew, it seems as if the pads on the F.Cu layer is being displayed as two concentric circles and I’m unclear as to what the outer circle is.

It’s almost as if the F.Paste and F.Mask layers are correct, but the F.Cu layer as being displayed as an annular ring. If I toggle the F.Cu layer visibility in F.Cu, the larger outer ring around a pad disappears, leaving the F.Mask and F.Paste layers looking as I expected.

Is the outer ring a keep-out, and if so, where is that dimension specified?

Attached are screenshots showing this with the LFBGA-169_16x12mm_Layout28x14_P0.5mm_Ball0.3_Pad0.3mm_NSMD footprint included with the standard KiCad libraries.

Note that in the Footprint Editor (top), we see that H14 is 0.3mm and the toggling the visibility of the F.Cu, F.Mask, and F.Paste layers all indicate this.

However, if we look at this footprint placed in Pcbnew (bottom), the F.Cu layer seems to show the pads as these two concentric rings. The F.Mask and F.Paste layers seem to be correct, but I’m confused as to why the F.Cu layer for the BGA pads look different.

My KiCAD version is 5.0.1-3 for Windows.

(1) Can someone else reproduce this with the LFBGA-169 footprint?

(2) Can you explain what I’m seeing here? Based on what I’m seeing it looks like the LFBGA-169 footprint is not possible to use due to overlap, or I’m just not understanding the UI (quite likely).


#2

I think what you are seeing is clearance tolerances. From the image it looks like you need to look under the second tab.


#3

@hermit is on the right track. Switching pad display to solid should clear things up a lot. (In outline mode it is hard to distinguish the clearance indication lines from the pad outlines)

I anticipate the next question to be how to reduce the clearance. (It will not really be possible to connect traces to the pads with the current setting.) It is set on the net level. Look under setup->design rules. Make sure you do not reduce it below what your manufacturer can produce.


#4

@jynik If you aren’t sure what Rene is referring to, see the button that I have the cursor next to. It is highlighted in blue showing that it is active (and thus showing all pads as empty circles instead of solid circles). Click that button to toggle the setting.
Cu%20Differences%20in%20Footprint%20vs%20Layout%20for%20BGA%20pads%20-%20Layout%20_%20Footprints%20-%20KiC


#5

Thank you all for the super quick and helpful responses! :smiley:

Switching to solid does indeed make things more clear.

Since I have your attention, could I trouble one of you to independently apply the OSHPark DRC rules and then look at the standard KiCAD footprints for the BGA-153 and/or BGA-169 in Pcbnew?

Based upon what I’m seeing, I’m under the impression that either:

  • I’ve failed to reduce some clearance items from their default values
  • OSHPark’s rules indicate they’re unable to produce this footprint

Based upon this blog post, I won’t be surprised if the latter is true… but a second pair of eyes would be greatly appreciated.

Cheers,
Jon