Export lines as dxf with square corners instead of circle

hey, in my footprint I have a layer, containing lines, that are exported as DXF files.

I then import the DXF file into Fusion360, where I’m designing plastic molds/parts.

The DXF file that’s exported contains lines as it should - but the performance in Fusion360 is really bad.

My intuition is that the there are too many polygons and that I should reduce the numbers

to do this, I’ve noticed that KiCAD exports a line with a circle at the tip of the line - as such, when I make a square/rectangle, the inner lines are nice 90 degree angles, but the outer lines are circular

image

My goal is to improve performance once in Fusion360, if I’ve indexed on polygon count incorrectly please speak up?

My question is is there a way for KiCAD to export a box, as a DXF, that is either infinitely ‘thin’ (thickness=0), or to use a square instead of a circle for the tip of the line?

Try unchecking the checkbox:
Pcbnew / File / Plot / Plot Format: DXF / DXF Options: [ ] Plot graphic items using their contours

Then report back if it works for you.

1 Like

this worked quite well; the performance improvement in Fustion360 was substantial

thanks for pointing out this option!