Experimenting with kicad-cli-nightly

Off-topic, we could have an optional tag for the 7.99

There is something off with this current version, I feel.

Running the DRC the CLI does not give me issues.

➜ kicad-cli-nightly pcb drc --all-track-errors --severity-all Primo_HW.kicad_pcb -o drc.rtp 
Loading board
Running DRC...
Found 0 violations
Found 0 unconnected items
Found 0 schematic parity issues
Saved DRC Report to drc.rtp

However, the GUI tells me a different story.

Another thing that I could not find on CLI is a way to disable the Test for Parity between PCB and Schematic

Application: KiCad PCB Editor x86_64 on x86_64

Version: 8.0.0~rc2-d50e0811fb~176~ubuntu23.10.1, release build

Libraries:
	wxWidgets 3.2.2
	FreeType 2.13.1
	HarfBuzz 8.0.1
	FontConfig 2.14.2
	libcurl/8.2.1 OpenSSL/3.0.10 zlib/1.2.13 brotli/1.0.9 zstd/1.5.5 libidn2/2.3.4 libpsl/0.21.2 (+libidn2/2.3.3) libssh/0.10.5/openssl/zlib nghttp2/1.55.1 librtmp/2.3 OpenLDAP/2.6.6

Platform: Ubuntu 23.10, 64 bit, Little endian, wxGTK, X11, ubuntu, x11

Build Info:
	Date: Jan 24 2024 15:04:49
	wxWidgets: 3.2.2 (wchar_t,wx containers) GTK+ 3.24
	Boost: 1.74.0
	OCC: 7.6.3
	Curl: 8.2.1
	ngspice: 40
	Compiler: GCC 13.2.0 with C++ ABI 1018

Build settings:

Someone broke headless drc 4 days ago and I kept forgetting to fix it. It’s fixed.

Schematic parity missing is because it’s tied to have a gui open currently lol

2 Likes