Exclude filled zone outlines while generating Gerber output

Hi there,
I have a filled zone of GND, some nets, and tracks connecting them on a single-sided PCB. I want to exclude the filled zone outline from the Gerber output. Is it possible in Kicad 6.0?

The Gerber output will then be imported in Flatcam and milled on the Mach3 controller. There is no reason to mill the filled area outlines (isolation routing), it just takes up time (the GND zone takes the whole PCB space). Currently, each time I import a Gerber file, I modify the extracted geometry manually and delete the border lines. But it’s (1) not always possible and (2) inconvenient.


Short answer:
I think you want: PCB Editor / File / Board Setup / Design Rules / Constraints / Copper / Copper to Edge Clearance In KiCad V6 you can set it to a very small value, but KiCad appears to keep a minimum of the zone clearance, while if you set it to a very small value in V7.0.0-rc2, then it will get that very small value.

Long answer:

The KiCad have the ambition for KiCad to be a professional tool, and they are doing a wonderful job at that task. It’s not that they don’t like “hobbyists”, a lot of their user base fall into this category. The reason is that if they aim for professional quality, they have an end product that can also be used by hobbyists, while if they only aim for hobbyists, they will never penetrate that other side of the market.

Combine that with the limited time of the people who are developing KiCad, and then there are no resources to develop features like this.

I also believe such a function should be built into your milling software, and not into KiCad. For “normally” produced PCB’s it’s quite important to keep copper zones away from the edges of the PCB, as this can cause “smearing” and shorts, especially on multi layer PCB’s.

So, if this edge clearance does not work for you, you have to find some other workaround. Maybe you can do something with custom rules.
Another option is to draw two outlines. You draw the “real PCB outline” bigger, and draw a “dummy outline” on a graphics layer, and only use that for your milling purposes.

1 Like

This is very specific to the way the board will be fabricated in this instance, not the design. Isn’t it really the job of the CAM software - Flatcam - to handle this?

Yeah, I was also thinking about it: it’s a feature of the CAM software to handle such things. It just becomes impossible to remove the outlines in Flatcam when the GND zone corners are so close to the nets or tracks and the CAM software decides not to create a separate geometry to denote the board outlines. Instead, the borders are merged with nets and tracks. There is no way in Flatcam, as far as I know, to exclude the filled zone borders from the isolation routing.

Anyway, let’s mark it as not relevant to Kicad.

My concern is that this gives yet another opportunity for accidentally sending bad Gerbers to the Fab for everyone else.
Once a design passes DRC, the output process has to be as foolproof as possible

1 Like

The cheatiest way is to unfill the zone (Ctrl-B) or delete it before exporting the gerber.


FYI - I use Coppercam for CNC milling PCB’s (IMO, the best PCB milling software I’ve expolored. Been using it about 7yrs now…)

User can set/unset any items to be milled from contours, lines, zones…etc… And, results are always perfect (for me)

It has limited Free use for the curious… and, though it’s a Window program, I run it on my Mac by using PlayOnMac (there’s also PlayOnLinux)… Basically, a one-click setup (almost)…

ADDED: Video showing a couple of Zones in CopperCam…