ESP8266 D1mini the electr. Enter rules for these pins?

Hello, I’m still trying to understand how to figure out how to enter the electrical rules correctly. Taking the D1mini as an example, do I now have to label the 3V3 as a power supply or as a power output?
The RST pin is an input on the D1mini. If I draw a three-pin pin: VCC, RST and GND, how do I have to connect the electr. Enter rules for these pins?

This is the pin properties in the symbol editor you are writing about?

We Germans are talking about the electric type.

VCC and GND are Power In

For your ESP8266, most pins are Bidirectional because they can be used as inputs or outputs. Your RST and ADCO are Inputs because they only accept a signal entering the IC. The 3.3V, 5V and GND are Power In, to run the IC.

Here is another example ; LM3524 SMPS control IC which may help you.

Pin 15 - Power Input. Power to run IC
Pins 1, 2, 9, 4, 5, 10 - Passive. Although Inputs, the signal required to make IC function does not need to be from an Output.
Pins 7, 6, - Passive. They are attached to an RC network to set oscillator frequency. They do not accept or give a control signal.
Pin 16 - Power Out. This supplies power to other components.
Pin 12, 13 - Open Collector
Pin 11, 14 - Open Emitter
Pin 3 - Output. Sends a signal out to be used by another component.
Pin 8 - Power Input. Power to run IC.

If you are ever in doubt, use Passive.

1 Like

So far so good, now I want to draw a UART interface for the D1. For example, the footprint is “Connector_JST:JST_EH_B4B-EH-A_1x04_P2.50mm_Vertical”.
How do I now have to type the interface electrically so that I can connect several in parallel?
Pin1 3V3 > ?
Pin2 TX > ?
Pin3 RX > ?
Pin4 GND > ?

Pins for connectors are all marked “Passive”.

Generally connector pins are given the type Passive. Have a look at those in the standard library.

As @retiredfeline suggests, open any connector or passive component (capacitor, resistor, inductor) with the Symbol Editor and then highlight the pins and observe the electrical type.

These are actually tricky. One is tempted to say well it could receive a signal so it’s an Input. But the relevant rule is: Does this have to have an Output or Power Output on the same net? Only then should it be labelled Input. Think of a logic gate input as your typical case. An opamp input isn’t such a case because they can be wired to passives for a summer, amplifier, integrator, etc. and not connected to an Output. So label such pins Passive.

1 Like

I see your point, you are correct. I don’t think I have ever used this IC with pins 1 & 2 connected to anything other than resistors. Here was me thinking I had found an IC that demonstrated a great variety of labels. I’ll make an edit.

How does that read now, kind Sir?

He, he, true confession time… I’ve never bothered to use the ERC. :slightly_frowning_face: A bit like 3D, I’m more interested in a real life board than a computer generated version :slightly_frowning_face:

Looks good good good good.

And it’s good good good night from me.

Thanks for the answer, I hope I understood correctly that this applies to all four pins.

Another thing is the layout of the pin table, there is so much space for number and name and for electrical type you have to constantly put your hands on it. And kudos to the developers of KiCad, it’s never been so easy to create a schematic, thanks for your work!

1 Like

I still have a problem: If I connect a Powerflag symbol, I get an error message. So far I always had to use two, one for GND and one for +5V.

You have set J5 Pin 2 to “Power output”, thus you don’t need a power flag (which also acts as power output). Power flags are only useful when you supply power by some component or through some fuse/resistor that KiCad won’t recognize as power output.

If you had set J5 Pin 1 to power output, too, you could (should) also get rid of the power flag on the GND net.

Or if you’re actually using J1 for powering your board, this is Kicad warning you that you have potentially two power sources connected at the same time, J1 and J5.

1 Like

I don’t see this problem.

Have you tried adjusting the width of the columns by putting the cursor on the boundary until it turns into a 2-way arrow and then dragging to change the width?

Maybe yours is different, I’m using Win11, and it always started like this.