Errors were encountered loading footprints:

Hi, this is my first run of 5.0.1.
I did couple of schematics and now it’s time
to look for proper footprints. However, Kicad refuses to cooperate.

Library Browser shows library names in plural (Crystals. Connectors, etc)
but in the folder configured in Kicad5 (c:\Program Files\KiCad5\share\kicad\modules)
most of the library name definitions are in singular (Crysal, Connector, etc)

What is wrong? I mean, am I first to see such a problem?

What shall I rename? Plurals to singulars or vice versa?

Thanks Rene for pointing me for the configuration file in
The problem seems to be that the library naming convention
is different between versions 4 and 5 (yes, I had installed version 4 before).
Where can I get proper fp-lib.table for Kicad version 5?
It seems, that template on github is stuck with version 4 convention…
For instance Capacitor(s) are defined in teplate on github as this:
But the directory name on my filesystem is named like this:
c:\Program Files\KiCad5\share\kicad\modules\Capacitor_THT.pretty\


Wrong repo :wink: (As explained in the repo description this is the archived legacy repo for version 4.)
You should not even need to do this. I updated the originally linked FAQ post to go into more detail. I also posted two more links in my previous answer. These should also help you out.

And the right repo is … where?

Explained in the faq articles i already posted above. (and in the readme of the repo you looked at :wink: )

I finally found the file here:

Hint: if it were also here (after Kicad5 install)
c:\Program Files\KiCad5\share\kicad\modules
life would be much easier…

It should be. In windows installers you need to select the installation of libraries. (should be the default setting!)

For linux i posted a faq article above.

Rene, everyone,
could there be a clarification in the FAQ what the “plugin type: KiCad” means?
This is the default, so does it mean that when there is a new release or update to the official libraries on github I will get these updates to my local machine also automatically?
Or is there a button or command-line “git pull” that I need to do to update my local libraries (in KISYSMOD/*)


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.