ERROR While Reading Netlist From Pcbnew Window

Situations like this will occur. Temporary problems with Git servers or Internet connection will generate this type of errors.

This is the price for keeping the data in cloud computing. As one of ST Microelectronics engineer said on one of the presentation: “One switch to rule them all”.

If i get this error message (or something similar)
I close PCBnew and restart it. Till now this has worked for me.
Sometimes i also get the same error in CcPcb.
As @keruseykaryu mentioned, it is a temporary problem.

If you don’t have a reliable internet connection, you could make a local copy of the pretty repositories.
This can be done from within the library wizard of PCBnew.

If you want all kicad libs with local copies, first delete them within the footprint library manager.
Next step: add them with the footprint library wizard.
In the first window select github repos and save local copy to.
You need to give a path with write access. (Keep the online path as is.)
In the next window select the libraries you want.

I’m not sure if this local copy is updated and when.
CvPcb works without internet connection when local copies exist.
(PCBnew should therefore also work.)

I tested it in the current nightly build.

1 Like