Error while loading the netlist. Missing footprints

Still the trick in v4.0.2, thanks!

I’ve just updated my version (which was the last 2013 stable version). I spent 1hour roaring like a mad man for the same reason of missing footprints, thanks for the forum. It is a bit silly having to return to eeschema to update once again the netlist but when you know the thing it works.

hoppefully the new version isn’t that different from the last one.

Thanks for the info. This almost drove me crazy.

I know this is a very old post, but it is an issue that also had me stumped for an hour. I am on Version 4.0.4-stable. The complete process is Schematic in EESchema -> Netlist -> Run CvPCB -> Save Netlist -> EESchema Create NETLIST again -> Save in EESchema -> PCBNew Read Netlist.

Why? 4.0.6 has been the official release since March
No new features, just bugs fixed

Will update soon @davidsrsb, but this won’t change the flow in any case. It is one of those traps, if you know about it, then it is not an issue. It is not intuitive workflow though. One would expects to go from CVPCB directly to PCBNEW (The way it used to be, before CVPCB was added to EESCHEMA)

CvPCB adds footprint information into the schematic file (footprint associations), which hasn’t been there before (unless you use pre-assigned schematic symbols, which the public KiCAD libs don’t have).
Afaik this was always the case:

There is no ‘tampering’ with the netlist going on - that was always EEschema’s job - to create it from the schematic file.

The process looks like this:
Schematic in EESchema -> Run CvPCB / Assign Footprints to Symbols -> Save in Schematic file -> EESchema Export NETLIST -> PCBNew Import NETLIST

Check the F2 field in the .sch files for your symbols.
Before and after you run CvPCB…

PS: and some of us don’t have this ‘problem’ as the symbols already contain footprint associations, so the process then becomes:
Schematic in EESchema -> Export NETLIST -> PCBNew Import NETLIST

Thank you for your comment. I will get more familiar with the contents of the netlist and .sch files. Luckily it is all human readable which is a big plus point for Kicad. :sunglasses:

The tools in the top toolbar are ordered from left to right in the order they are intended to be used. (at least as far as I remember. I have no access to kicad right now.)

You are correct (although cvpcb used to be an operation you launched outside of eeschema). The trick here though is to go back left on the toolbar and re-export the netlist after you completed (and saved inside cvpcb) This is the non-intuitive part I am referring to. But I will not be caught again at least ; )

Hi All. I’m still getting the same problem: “Error: No footprint defined for component ‘Connector_1’” etc as above. I’ve tried all combinations as suggested above and I’m getting nowhere. :sob:Is there any problem where choosing the “D:” drive to install on would cause a problem with this please?

No footprint defined sounds like a different problem. Is the footprint field of the symbol representing this part in question set? (press e while your mouse is above the symbol. What does the footprint field say?)

AHH, the footprint field is blank!!

Every symbol needs a footprint assinged.
In this post i explained why: (everything below the horizontal line.)

1 Like

…so you’re saying I have to find and define the footprints manually?

Or make sure it is set in your lib. (atomic symbol)
How else should kicad know what footprint it should connect to a symbol?
(In the official lib we try to get to the state where all non generic symbols have a default footprint assigned. But we have not yet reached that stage.)

1 Like

I’m sorry Rene, I’m new to this program and don’t know how to “set in your lib. (atomic symbol)”. Could you put it in simple terms for me. This is the 5th or 6th PCB program I’ve struggled through today trying to find something that works well, and I’m tired and very disappointed so far.

As described in the post i linked, you have a few options how to connect a symbol to its footprint. (Kicad is very flexible. This allows for multiple conflicting workflows to co exist.)

The original way in kicad was to have only generic symbols without any footprint assigned. There is a tool called cvpcb that shows you in tabular form all symbols of your schematic with their footprint fields. This tool can be used to assign footprints to all symbols after you finished designing the schematic.

You can also set the footprint for one symbol using this symbol properties dialog you already opened. Select the footprint field and press the footprint browser button. For more details please read my old post about this.

As the lib grew (and the userbase became more professional) we found that for a lot of components the generic symbol approach does not make sense. This is why a lot of symbols are created as atomic component. This is simply a symbol with the footprint field set in the library. (via the lib editor)
Setting the footprint field is done similar to when done from the symbol properties dialog of eeschema. Here it is called field properties dialog. The assign footprint button opens the footprint browser. (Click the image for larger resolution)

This type of symbol setup requires more work during the symbol creation process (and possibly a larger lib) but less work while designing your circuit.

Have a look at the links i posted above for more details.

Here a written tutorial on how to create a symbol.
A good beginners guide for kicad is the getting to blinky video series by @ChrisGammell

As with all tools there is a lot to learn. But i can assure you it gets easier over time. (Getting used to the library editor and footprint editor is one of the most important steps for any pcb design program)

1 Like

I would just like to second the recommendation for the “Getting to Blink 4.0” videos. I watched the series before I even downloaded KiCAD and I referred back to it several time while doing my first board. Very helpful!


I don’t know if anyone else mentioned this, but somehow I had generated a netlist via the OrcadPCB2 and it had made it the default automatically. Just switch it to Pcbnew and it worked!