Error while loading the netlist. Missing footprints


#1

Hi,

I have a problem with the import of netlist in Pcbnew. I know that it was already discussed, but previous solutions, unfortunately, do not work in my case.

The problem is that after completing scheme and choosing the foot prints, I’m trying to load a saved netlist in Pcbnew but I get an error report as follows:

Info: Reading netlist file “C:\Users\Rogalski\Desktop\test\test.net”.
Info: Using references to match components and footprints.
Error: No footprint defined for component ‘P1’.
Error: No footprint defined for component ‘P2’.
Error: No footprint defined for component ‘R1’.
Info: Checking netlist component footprint “P1:/55E0B36C:”.
Error: Cannot add new component “P1:/55E0B36C” due to missing footprint “”.
Info: Checking netlist component footprint “P2:/55E0B474:”.
Error: Cannot add new component “P2:/55E0B474” due to missing footprint “”.
Info: Checking netlist component footprint “R1:/55E0B4F0:”.
Error: Cannot add new component “R1:/55E0B4F0” due to missing footprint “”.

Footprints were selected only from the original libraries from github.The strange thing is that I can view these footprints in Library browser, and even add them to layout in Pcbnew. Do you have any ideas what I’m doing wrong? Previously, I worked a lot with the older version of KiCad, but I’ve never had such a problem.


#2

After choosing footprints with cvpcb, did you re-export the netlist so that the footprint fields are updated in the netlist?


#3

The doc.kicad-pcb.org document need update. I found that the document not clear point this step for recreate net list file. and the current document for start user has some bugs when introduct for pin electric type for PIC12508A VCC and GND.

I THINK THAT IS THE KEY STEP FOR CREATE PCB FILE.


#4

After selecting footprints, I have saved netlist by using “Save Edits” button in cvpcb. If I remember correctly in older versions of KiCad it was enough, to later import the netlist file in pcbnew. How can I re-export it?


#5

Just go back to eeschema and click on the netlist icon after you’ve saved the footlprint info in cvpcb :wink:


#6

So, I too ran into this today and it got me wondering, does cvpcb automagically update the sch file with the correct info now? It doesn’t seem to generate a cmp file any more (I would say this is an improvement). Just trying to see how this flow works now. Using build 6097 on Ubuntu 14.04 LTS.


#7

Although the .sch file is updated with footprint info, in order to proceed to the layout phase in pcbnew, you will -of course- still need to (re-)export the netlist.

I’d prefer to have cvpcb automatically update the netlist file aswell, because that is almost always the next step after assigning footprints. I’m not sure if cvpcb will eventually be phased out - I think I can recall a screenshot from Tom with a cvpcv-style footprint assignment directly from eeschema, but I’m not sure if that’ll be an ‘extra’ or a replacement.


#8

Or your symbol libraries could have parts which already have a footprint baked into them, so CvPCB is not necessary and you do the footprint assignment once.


#9

Still the trick in v4.0.2, thanks!


#10

Updated from a 3 year old version. This had me stumped for an hour. How silly. Thanks for the “googleable” info


#11

I’ve just updated my version (which was the last 2013 stable version). I spent 1hour roaring like a mad man for the same reason of missing footprints, thanks for the forum. It is a bit silly having to return to eeschema to update once again the netlist but when you know the thing it works.

hoppefully the new version isn’t that different from the last one.


#12

Thanks for the info. This almost drove me crazy.


#13

I know this is a very old post, but it is an issue that also had me stumped for an hour. I am on Version 4.0.4-stable. The complete process is Schematic in EESchema -> Netlist -> Run CvPCB -> Save Netlist -> EESchema Create NETLIST again -> Save in EESchema -> PCBNew Read Netlist.


#14

Why? 4.0.6 has been the official release since March
No new features, just bugs fixed


#15

Will update soon @davidsrsb, but this won’t change the flow in any case. It is one of those traps, if you know about it, then it is not an issue. It is not intuitive workflow though. One would expects to go from CVPCB directly to PCBNEW (The way it used to be, before CVPCB was added to EESCHEMA)


#16

CvPCB adds footprint information into the schematic file (footprint associations), which hasn’t been there before (unless you use pre-assigned schematic symbols, which the public KiCAD libs don’t have).
Afaik this was always the case:

There is no ‘tampering’ with the netlist going on - that was always EEschema’s job - to create it from the schematic file.

The process looks like this:
Schematic in EESchema -> Run CvPCB / Assign Footprints to Symbols -> Save in Schematic file -> EESchema Export NETLIST -> PCBNew Import NETLIST

Check the F2 field in the .sch files for your symbols.
Before and after you run CvPCB…

PS: and some of us don’t have this ‘problem’ as the symbols already contain footprint associations, so the process then becomes:
Schematic in EESchema -> Export NETLIST -> PCBNew Import NETLIST
:nerd:


#17

Thank you for your comment. I will get more familiar with the contents of the netlist and .sch files. Luckily it is all human readable which is a big plus point for Kicad. :sunglasses:


#18

The tools in the top toolbar are ordered from left to right in the order they are intended to be used. (at least as far as I remember. I have no access to kicad right now.)


#19

You are correct (although cvpcb used to be an operation you launched outside of eeschema). The trick here though is to go back left on the toolbar and re-export the netlist after you completed (and saved inside cvpcb) This is the non-intuitive part I am referring to. But I will not be caught again at least ; )


#20

Hi All. I’m still getting the same problem: “Error: No footprint defined for component ‘Connector_1’” etc as above. I’ve tried all combinations as suggested above and I’m getting nowhere. :sob:Is there any problem where choosing the “D:” drive to install on would cause a problem with this please?