Error when saving KiCad 5 project in KiCad 6 (Windows 10)

I created a backup of a KiCad 5 project (designed using version 5.99) and then opened it up in KiCad 6 (version 6.07 specifically). When I pull up the PCB or schematic there is a message that I’ve opened up a file from an older version and that it will be converted to the new format upon saving. Unfortunately when I go to save either file I get the error message below. I’ve tried running KiCad 6 as an administrator and that didn’t help. Has anyone else experienced this issue or have an idea of how to resolve it? I’m not sure if it’s a bug in the software or some issue with Windows 10. It happens on two different computers of mine running this OS.

Error 1

1 Like

Hi, v6.07 is slightly outdated, please install latest v6.x and retry. But really not sure if that will help.

As I imagine, tmp files are used when some kind of virtual filesystem is involved (google drive, one drive), maybe your documents folder is located in onedrive? Try copying folders somewhere to your local hdd (c or d drive) and retry.

1 Like

Are you sure your project directory is not read-only?

1 Like

KiCad 5.99 is not KiCad 5! It’s a nightly build of what would eventually become KiCad 6. It also could mean any of literally thousands of nightly builds.

2 Likes

I went ahead and updated to the latest version (6.09) which didn’t seem to help. I store my projects on a NAS, but did copy one to my local machine when I first noticed this error. That didn’t seem to resolve the issue either. I tried unchecking the “Read Only” attribute on the Temp folder and that also have no effect. Ultimately I used the “Save Copy As” option on the PCB and schematic to create a version that is seemingly compatible with KiCad 6.

@OnCor

If I read your original post correctly:
You designed a project in 5.99 then placed it in 5.x.x and now you are trying to open it in 6.x.x

I think your problem lies with placing the 5.99 project back into 5.x.x, not with opening it in 6.x.x
5.99 was not backward compatible with 5.x.x, just as 6.99 is not backward compatible with 6.x.x
As Craftyjon wrote: 5.99 was a prototype 6.0.0, just as 6.99 is a prototype 7.0.0

Have you tried opening your original 5.99 project directly into 6.x.x?