Error opening Kicad [solved]


I am a newbie in Kicad. I installed Kicad stable version 64 bit in my windows 7 64 bit machine. Also I was able to do a turorial .Created project and schematic , pcb layout and gerber files successfully. But today when I tried to open a downloaded project from numato lab site I get error “file’x:\xx\’ , line 859 : ‘=’ expected”. Why do this happen? I tried to open through File -> Open Project in Kicad main window. Any suggestion on how to open project.

Thanks in advance.

With Regards

It’s probably not a Kicad project. What is the URL of the project you downloaded?

This link?

The .pro file in that board folder there doesn’t have 859 lines… and the projects loads fine in BZR6608 too.

Line 89 though has an entry with two hyphens:

I wonder if this is causing problems with Windows. I try to not to use the more dangerous characters affecting Windows/Linux portability

Hm… as I said, no probs for my install (Win7 64Bit).

Underscores and Hyphens won’t cause problems afaik - they’re used on either side regularly.
Slashes and Backslashes are most troublesome for me.

Thank you so much for your replies. Sorry for my delayed reply, I was not available some days.
Finally I opened project after a reinstall and rescue operation and loading associated libraries.
With regards

1 Like