Error on STEP export

I tried doing a step export of my PCB, it shows fine in the 3D viewer, but I am told:

“Unable to create STEP file. Check that the board has a valid outline and models.”

How can this be?

The STEP exporter is a bit strict in regard to the contour (even if the 3D preview works fine) of the board as seen from previous posts.

Hope it helps

Thank you, but this is simply a square. Nothing funny about it. I can do no more to my edge to make it work. Is the fact that my board is outside the page boarder an issue?

Still, did you run DRC check to see what it says about the edge?

I also recommend importing the board file from FreeCAD/StepUp. It has worked for me when KiCad export has failed. Of course it’s good to report bugs and get them fixed if there are any, but until then the external application may work better.

DRC check does not reveal any errors. I manually typed in the coordinates as round numbers in mm (95x95mm).

Do you mean importing a DXF file as the border? bit extreme that?

Sorry, I meant “importing the board file into FreeCAD from within FreeCAD”. If you have installed the StepUp workbench you can just open a KiCad board file in FreeCAD.

Most of us have learned to press and keep some key down, or are prepared to write lengthy stupid sentences (like yours) for somewhat comical effect.

1 Like

if it is only a square border, maybe you could share the kicad file for the people that are more experienced to take a look ? Never had a problem with a square border before.

How do I add a file here?

Try simple dragging or copy/paste.

SLKCD012.kicad_pcb (390.2 KB)

The 3D files aren’t included, so the result isn’t the same. It succeeds for me with the models it can find. It’s more probable that some of the 3D models you’ve got aren’t good.

If you still want us to test further you have to archive the footprints, see Cache/Embed 3D Model in Footprint? and the action plugin linked there…

The project archive plugin fails to run properly with an error saying: ascii codec can’t decode byte 0xe2 in positions 33: ordinal not in range (128).

But that is ok, 3D models are now the least of my worries because now PCB new has decided that nets for pins on a header need to be jumbled up so my whole design and hours upon hours of work are now useless.

I opened the kicad project from FreeCAD and it complained about my crystal model. Not sure why, I made that one myself so i know there is nothing funny in it. Could it be the extruded text I had on it?

It would of course be useful if the error messages could be more specific.

Which Report message did you get at the log?

It would of course easier to debug if you would add your problematic model :wink:

“I made it myself” => “there’s nothing wrong with it”
Non sequitur. It depends on how you made it. There may be something wrong even if you don’t know about it.

1 Like

Well that was the point of using the export project plugin so that I could share the entire project with models but it failed as per above. The offending step of the crystal is attached.

IQXC-180.stp (407.2 KB)

Apparently it’s a multi part model, well I am not sure what it means as it’s a single body, like i say, I made it so I know there is no weirdness like that.