Error : maximum line length exceeded

Hi, guys

I was making an PCB it was completed but suddenly due to power outage the laptop shutdown, but I saved the file before it happened. Now when I am trying to open the PCB the error is maximum line length exceeded? what to do about it ?

Help > About > Copy Version Info

Paste that here for starters. Also, if it is a project that you can share, you can post it here to see if others can open it.

not working.rar (381.8 KB)

Application: KiCad (64-bit)

Version: (6.0.1), release build

	wxWidgets 3.1.5
	libcurl/7.78.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 19044), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
	Date: Jan 15 2022 13:36:27
	wxWidgets: 3.1.5 (wchar_t,wx containers)
	Boost: 1.76.0
	OCC: 7.5.0
	Curl: 7.78.0-DEV
	ngspice: 35
	Compiler: Visual C++ 1929 without C++ ABI

Build settings:

I actually already tried to open it on another laptop and same error

Both the schematic file and the PCB file are damaged. I could not even open them with a text editor. I’m also having problems with .rar files. If you want to share files with others, it’s much better to use a generic format.

Do you have a recent backup?
If you have a backup of your project, then it’s very likely the easiest way to restore your project. By default KiCad creates a backup directory in each project.

If you don’t have any backup, then Reverse engineering KiCad project from Gerber files is probably your next best option.

Apart from that. KiCad V6.0.1 is quite old, and there have been quite a lot of bug fixes in the last half year. A newer KiCad version is released approximately once a month and the current version is KiCad V6.0.7.

Yup had backup, otherwise I was totally ■■■■■■ and at that time I did not even generated gerbers.

I also tried to open it in text editor and nothing showed up then I opened it in vscode and everything was null, I guess due to sudden shutdown for some reason it corrupted everything.

Do you have any file recovery software? The way modern file systems work they don’t mark the ‘old file’ as obsolete until the ‘new file’ write is complete to prevent this kind of loss. I know SCSI drives have batteries to make sure they can finish that operation in situations like this. Sounds like you lost power at the exact moment the write was happening so it shows the new file which never got written.

Unless you do have backups you are out of luck.

  • 0      0 1865890 indsustrial airpurifier.kicad_pcb
  • 0      0 243492 indsustrial airpurifier.kicad_sch

Both files contain only zero byte values.

The project file reads ok with kucad 6.99.
gerber files read ok and appear usable.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.