Error loading schematic File


#1

Today I tried to load a previously made schematic and received this message. “Error loading schematic file, Z:…, Invalid PNG data”. I have the file.sch and it looks OK, there is similar text in it compared to other schematics I have. Is there something I can do to retrieve this file, or do I have to re draw it? Mike


#2

You should be able to repair it, at least partially. Does your schematic have embedded images in it? Error message indicates that something is wrong with the image data. If you find it in the .sch file and delete it your schematic may be revived. Images are enclosed in $Bitmap and $EndBitmap tags use them to quickly identify which sections to remove.

And don’t forget to save a backup of your file before you do any modifications.


#3

HEY! That did it. I removed all the stuff between and including the bitmap tags and the schematic loaded. I only lost a picture of a transistor that displayed the EBC leads. Thanks a million. You saved me a lot of time. I wonder what was wrong with the bitmap. Was the PNG in the error message a clue? Mike


#4

Glad that worked.

Yes.