Error loading projects, schematics, pcb files into Kicad

Hi, once I click on the schematic file, an error message indicates the file is empty which isn’t. When clicking the board file, a different error message appears indicates the board file can’t be loaded. Any ideas?

Thank you for your time,

Use an editor to see what is in the sch file.

Have you tried to open the backup?

Make a safety copy of the backup file first
For the OP, what KiCad version and OS?

Is this for the eagle import? At least in the past there was a bug that schematic pages with description could not be imported (as KiCad then tried to make file names with a newline character which is not supported by file systems)

Indeed.

There is much unclear. Where does that schematic file come from? Do you have a KiCad project at all, or are you clickin on it in a file browser?

Thank you for your response. Here is what inside the file by note editor.

I am using v5.1.9 via Windows 10.

Thank you for the response. No, it is Kicad based schematic.

This is a demo project, I need to see its schematic in order to go further.

Let me know what information missing for further clarification.

The schematic looks like it is in the new file format. You will need a current nightly build to open it.

Hello Reno, You were right. After downloading the newest version, I was able to open the files.

Thank you,