Error loading netlist


#1

Hello guys,

I received the following error with the project specific libraries

Error loading netlist.
IO_ERROR:fp-lib-table files contain no lib with nickname ‘newlib’ from
c./msys64/home/nosterga/MINGW-packages/mingw-w64-kicad-git/src/kicad/common/fp_lib_table.cpp : FindRow() . line 623.

I had created the net list and associated the components with my library. But i get this error when i created new pcb and pressed read netlist. Kindly suggest what could be the solution.

Regards

Sriniketh


#2

does the list of libraries look the same both in:

  1. cvpcb / preferences / footprint libraries
    and
  2. pcbnew / preferences / footprint libraries manager

if those look the same and point to actual existing libraries on disk or on github it should work.


#3

Hello,

I have encountered similar problem. After opening Pcbnew and “Read netlist” I have a message:

Error loading netlist.
IO_ERROR: fp-lib-table files contain no lib with nickname ‘libcms’
from
C:/Jenkins/workspace/windows-kicad-msys2-stable/src/kicad-4.0.1/common/fp_lib_table.cpp : FindRow() : line 623

I have checked the libraries in cvpcb and pcbnew and they are identical. Anyway, problem still exist.
What else could be done?


#4

I had this error, too. When I had some screw-up in my libs. Like, wrong library, or no library in cvpcb.
Very strange. I’d check libs again, maybe there is a missing one… Just go thru cvpcb and check, if the lib is really ok. I mean, delete, assign again.


#5

Thanks for reply!

Strange thing is, I just downloaded and installed 4.0.1 version of Kicad, to get rid of the other library problem (missing footprints). Now I have all footprints (works fantastic, good job), but I can’t bring netlist to the Pcbnew due to mentioned issue.
Because of recent download/install, I do assume, all libs would be up to date.

  1. Is it any way I can check if all online (github) libraries are in place?

  2. –> to sq5rix mainly: do you mean go through all components, delete assignments and then assign footprints to them, or something else with libraries?

I will try delete/reassign today afternoon and let you know.


#6

Open EEschema, run CVpcb via button in the upper part of the window and tell us what you get there.


#7

libcms is one of the old libraries, so it sounds like your project has parts which need updating.


#8

Hello again,

Deleting/re-assigning components did not helped.

Joan_Sparky: there is three parts, left - libraries, middle - my assignments and right - list of selected library (from left part) items.

Anyway, thanks to your clues I have solved the problem. Looking at files interesting thing for me was, that files were edited today, anyway no date was changed for any file, except .sch. So, I took all files, moved them to other folder and generated again. This solved my problem, and exactly --> re-generating the netlist.

Once again, thanks all for your input!


#9

Hi

I see you solved - good news!

I was not precise, sorry. What I do:

Reassign offending library by deleting in CVPCB and assigning again (not all, I meant all offending)
Save, generate netlist
Read netlist in pcbnew, with replace footprint option.

Tom


#10

Just putting this here in case someone has the same issue:
I had the issue in Debian with KiCAD installed with the package manager, when switching from my laptop to my desktop.

The global footprint libraries were not the same on the two machines. And I think if the package manager updates and adds a library, the KiCAD global libraries don’t get updated automatically. So I needed to check which libraries were failing and simply add them to the global libraries and it solved my issue.


#11

FYI: I ran into this same issue after updating to KiCAD 4.0.7… after several headbanging hours, I figured out that KiCAD is now case sensitive… my issue was ultimately that the actual file names had capitalization, whereas the same names were all lowercase in the Footprint Libraries Manager; previous versions didn’t care, but now they do.