Error loading footprint 2

I am using macOS Catarina 10.15.2.

I have installed kicad5.1.5 on a PC that has never installed kicad.

I tried to use something stored locally, but when I just installed it couldn’t read the symbol or footprint.

symbol has created a new default global sys-lib-table by adding backup to the sys-lib-table file at the time of installation.

I thought footprint could be solved by deleting fp-lib-table once and recreating it.

When I deleted fp-lib-table and tried to create a new one, the default global footprint could not be selected.

I don’t know the cause.


For some reason the libraries were not installed (or at least the default lib table was not installed where your operating system expects it).

Check if the libraries are there somewhere in your system (in linux it is under /usr/share/kicad for windows in the installation directory under C:\\programs\kicad not sure if something similar exists for mac as i never used one.) If they are then manually add the libs to the library table via the library managers. If not then download the libs from github and add them either manually or copy the supplied lib table to your user configuration page.

See: Library management in KiCad version 5

  • section: Options to download a particular library version (for the advanced setup)
    • explains how to download the libs and how to add them to your installation
  • section: Using the library manager
    • to learn how to add the libs if they are already on your hard disc

Thank you very much.
I will investigate.
The rough reference path seems to be correct, but I examine it.
Also examine the possibility that it can not be read at all due to the difference in the version of lib.

I checked if the library was in the right place as pointed out.
I think the location stored for the path you see is correct.
If you delete the symbol library manually as a trial, the symbol will become unreadable.
In the case of footprint, unlike a symbol, even a reading error is not displayed.

KiCad does not automatically load any libraries! You must add them to the library tables. (See the FAQ link posted above)

And yes normally the installer takes care of the first time setup but you will need to do it manually as the installer failed

I am not sure i understand what you mean here. (your screenshots do not really tell any story other than that the library tables are in fact empty)

I understand the cause
Nothing was written in fp-lib-table
So, fp-lib-table source
Copied and pasted

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.