Error in loading footprint

Hi,
hope you are doing good.
I am using kicad for designing PCB for our application.
I am unable to find the generic footprints and i see a message saying
“error in loading footprint” with list of all generic footprints.
how do fix this issue?

Try to track down the problem by reading some basic information about the library setup, Library management in KiCad version 5.

  • Are the libraries installed?
  • Do the path variables point to the correct places?

Also, you don’t give what version of KiCad you are using and what platform. Go to the About window in KiCad and use the button to copy the version info to the clipboard (On my 5.1.7 in English the button is labeled “Copy Version Info”.). Then paste the results here.

If you are on Linux (I’m not so I’m just going by recollections of past conversations here), you may need to also install the libraries in addition to the main KiCad package.

Application: KiCad
Version: (5.1.7)-1, release build
Libraries:
wxWidgets 3.0.5
libcurl/7.71.0 OpenSSL/1.1.1g (Schannel) zlib/1.2.11 brotli/1.0.7 libidn2/2.3.0 libpsl/0.21.0 (+libidn2/2.3.0) libssh2/1.9.0 nghttp2/1.41.0
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.5 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.73.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.71.0
Compiler: GCC 10.2.0 with C++ ABI 1014

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=OFF
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON

Ok, have you ever had v4 installed on that machine? If so stale settings may be left behind. See this FAQ entry (also linked by @eelik above):

And my suggestion for a procedure in this post (note some of the follow up conversation):

If not that, when installing on Windows you are given the option to not install libraries. Maybe try reinstalling making sure that the only install setting that is turned off is the environment variables one.

The answers above are generic because we are left in the dark. You really need to give us the full error information. (So at least a screenshot of the error window or possibly copy the content and then format it nicely. The latter has the benefit that somebody can search for the error message and get pointed to the forum.)

A screenshot would give a clear understanding of what happened and what needs to be done.

Hi,
Hope you are good.
sorry for the late reply.
here is the error which i see

i see that the path for the files are a bit weird. all i could do for my project is replace the path for required footprints.
like image given below

should I do it for all of them manually or is there any way?

It seems there is an “s” missing in the KISYSMOD variable. (your working paths are use modules while the non working ones use module)

Path variables are set in preferences -> configure paths (in the kicad main window, a similar entry should also exist in all other windows) . Adding the “s” at the end of the path for KISYSMOD should fix your issue.

1 Like

this helped.
Thanks a lot