Error: Global library not writable

For the last few days I have been getting this weird error that my global library is not writable when I want to add a new symbol. I am using the Nightly version, but I might unsure if it is a bug related to that or I have somehow messed up the settings. Is there any option that sets the library as writable or not?

No, KiCad doesn’t have any special options for file handling. What is your global library? Your personal library? The KiCad’s official library? What’s the location in the filesystem? Have you checked the file (and folder) permissions?

Tell also the exact version information and the OS/platform.

[Edit] Oops, I borked.
Mixed up “global library” and "KiCad default library.
What follows may be irrelevant.


This is not a bug, it is a feature.

KiCad’s libraries are read-only because the can get updated with an update of KiCad, and if you modify them by adding your own schematic symbols or footprints then they will be lost.

Unless you have backups of course, but if you put your stuff into the KiCad libraries, I am not sure if you make backups…

The proper way is to create your own library and put any custom symbols or footprints in it (the mechanism is very similar). and then add your custom libraries to the library tables.

An when you have your custom symbols in your custom library, it’s also easy to back them up. :slight_smile:

1 Like

OP said it’s a global library, nothing about it being kicad official library.

Thank you all for the responses, they helped me. My question was not clear enough and this caused some confusion, so I will try to explain.

I was indeed talking about the KiCad Official Library which also happens to be global. However, I cloned it from GIT, so that I have the newest parts and to be able to contribute to it. It seems that after one of the nightly updates my settings were updated and paths were no longer pointing at my GIT folder.

Issue closed

Edit

I spoke too soon. Now I get this message

image

and I don’t know what the running process is or how to change the paths. Any modification I do are reset after restarting KiCad

Looks like you are using Ubuntu: this is an issue that we’re working on fixing: https://gitlab.com/kicad/packaging/kicad-ubuntu-builder/kicad-daily-package/-/issues/8

IMHO, you should never write to the libraries that come with KiCAD installation. Create your own libraries, you can copy from these preinstalled libraries to your libraries.

1 Like

Remember that “However, I cloned it from GIT, so that I have the newest parts and to be able to contribute to it.” For that purpose one must of course write to the cloned repo.

Does anybody know where and when Kicad saves settings including default paths?

For 5.99: see https://docs.kicad.org/master/en/kicad/kicad.html#settings

But, Ubuntu nightlies are special and use an env script (at least, until today, it just got removed) that overrides the paths for the libraries.