Error: Cannot add R1 (no footprint assigned) on KiCad 6.0

Greetings, comrades! I hope you’re all doing well.

After updating the PCB from the Schematic as shown in Picture 1:

An intimidating pop up shows and an error “Error: Cannot add R1 (no footprint assigned).” appears as shown in Picture 2:

How to fix the error “Error: Cannot add R1 (no footprint assigned).” when we update the PCB from the schematic?

Thank you!

Every symbol on the schematic side corresponds to a footprint on the board. You have to make an assignment (on the schematic) which footprint should be used on the board.
Some symbols already contain such an assignment (these are “fully defined” symbols) in the library, others (such as your resistors) don’t.
So doubleclick the symbols to get the symbol-properties-dialog and click into the footprint-value-field. You will get the footprint-library-browser window to select an appropriate footprint for the symbol.
Or use Tools–Assign Footprints to get a window for the footprint-assignment of all symbols on the schematic.

This question shows that you are new to Kicad. Please consider to read through the Kicad-documentation, these question for instance is already answered at the getting-started guide:

1 Like

Thanks you for the help, @mf_ibfeew ! I have now figured out how to fix the error “Error: Cannot add R1 (no footprint assigned)” on KiCad 6.0.

The steps on how to achieve it is:

Go to “Run footprint assignment” icon as shown in Picture 1:

A weird pop up would appear as shown in Picture 2:

To really assign a footprint for a particular electronic symbol, let’s take the Resistor R2 as an example on how to put a footprint for use in PCB creation. Click the R2 as shown in Picture 3:

Look at the left side, find the word “RESISTOR_THT” as shown in Picture 4:

Look at the right side, find the words “Resistor_THT:R_Axial_DIN0207_L6.3mm_D2.5mm_P2.54mm_Vertical” as shown in Picture 5:

Now click it, you should get something like this just like in Picture 6:

Click OK!

Now go again to your project and click “Update PCB to Schematic” icon as shown in Picture 7 and click it:

You got a nice pop up with no errors or warnigs as shown in Picture 8:

And that’s how we fix the error “Error: Cannot add R1 (no footprint assigned)” on KiCad 6.0.

Welcome to my TED talk…:slight_smile:

Note: The actual footprints used on the project came from this outdated documentation of KiCad as shown in Picture 9:

3 Likes

That’s not a “weird pop up”, that is the normal assign footprints window. (What used to be called CVPCB, I forget what the acronym stands for but my hazy recollection is it was a hold-over from the original French that KiCad was developed in (the original developer is a French person). Ah, found the meaning here: Non-devs: what do you think of the app names? - #3 by vini_i) Some people don’t use it because there are several ways to assign footprints, and an ERC check will flag missing footprints. But if you don’t use ERC for personal workflow reasons, just checking it can be a quick scan to make sure you didn’t forget to assign footprints to some symbols. Other people heavily use it as part of their normal workflow.