Erroe message: Symbol C1 pad 2 not found in Footprint

Hi Experts,
I am trying to make a minor change in an existing schematic for an existing board.
The change I made was to remove a pull-up resistor, everything else remained the same.
Now, after DRC, footprint assignment,
and netlist generation in EEschema, when I try to update the layout in PCBnew I get the following message: Quote"
Error: Symbol C1 pad 2 not found in footprint. Capacitor-THT: C_Disc_D3.0mm_W1.6mm_P2.50mm
"Unquote
The strange thing is that:
a. Both the capacitor symbol and the footprint are from Kicad libraries
b. There are more than 10 capacitors with the same symbol and footprint, but the error is reported for capacitor C1 only. Reversing the change didn’t make any difference.

The error message screenshot and KiCad version info files are attached herewith.

KiCad Ver. Info.pdf (69.3 KB)

What could be the possible cause for the error? Has the Kicad library become somehow corrupted?
But then why is the error message only for one capacitor?

Kindly advice. iF additional project files are needed, please let me know.
Thanks for your help in advance.
Best regards

KiCad makes copies of library footprints, and saves them in the PCB.
If you’ve edited a Footprint from Pcbnew, then you may have accidentally changed then pin name of pad 2.

The simplest way to repair it is probably to simply delete the footprint from the PCB, and then go back to Eeschema and update the PCB again with [F8].

A slightly more complex method is to Edit the properties of the C2 Footprint in Pcbnew, and then choose "Update Footprint from Library…"

You are also using KiCad V5.1.7 while V5.1.8 has been released a few weeks ago and has some bug fixes. Maybe an update helps.

If this does not help then the simplest is to zip the whole project and upload it here. You can remove some unneeded files from the zip file to make it smaller such as the backup files and the “fp-info-cache” file which can be quite big and is not very important.

1 Like

Hi paulvdh
Thanks for your fast response with two solution options.
For the sake of learning, I tried both methods one by one and both of them worked the first time.
The problem is solved. Your solution proposals are really very helpful.

I didn’t know about the V5.1.8 release. Of course, I will download the latest version now.

Thanks again and best regards
Starter99