Erratic operation with Drag 45 on track

Hello everyone, I find the operation of the Drag 45 degree mode with the current version of PCB_Design a little special, if I modify an angle of a track it modifies the entire track erratically. In version 5 we do not have this type of operation. Should we make a particular setup or is it a bug?


I want to adjust the bottom green track !

This kill the Top ! ! !

Thank you.
My version:

Application: KiCad

Version: (5.99.0-10293-g7c64dba333), release build

Libraries:
wxWidgets 3.1.4
libcurl/7.74.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 19042), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Apr 14 2021 12:03:23
wxWidgets: 3.1.4 (wchar_t,STL containers)
Boost: 1.75.0
OCC: 7.5.0
Curl: 7.74.0-DEV
ngspice: 34
Compiler: Visual C++ 1928 without C++ ABI

Build settings:
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
KICAD_SCRIPTING_ACTION_MENU=ON
KICAD_USE_OCC=ON
KICAD_SPICE=ON

Your version is already old, please update. There are new changes in the routing algorithms. (It may be better or worse for some use case.)

Check if you have “Optimize track being dragged” option turned on.
If you don’t want the router to mess with your entire track, change router mode from Shove/Walkaround to Highlight collissions mode.

Note that I highly recommend people use Walkaround as the default mode if they don’t want shoving behavior, not Highlight collisions, and report issues with the router. Highlight Collisions mode is much more limited and is not really an efficient way to use KiCad for most people, especially working with dense designs. We would much rather have issues reported than people just switching to Highlight Collisions mode because of some issue.

This particular issue has already been reported: https://gitlab.com/kicad/code/kicad/-/issues/8310

1 Like

Fully agree regarding the reports, just wanted to provide a solution for the OP.

1 Like

In this case, the workaround of turning off “optimize track being dragged” should be enough, no need to use Highlight Collisions.

Ok, thanks to all, first I install the latest Nightly release :

Application: KiCad PCB Editor

Version: (5.99.0-10444-g64d35ecebc), release build

Libraries:
wxWidgets 3.1.4
libcurl/7.74.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 19042), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Apr 29 2021 09:07:48
wxWidgets: 3.1.4 (wchar_t,STL containers)
Boost: 1.75.0
OCC: 7.5.0
Curl: 7.74.0-DEV
ngspice: 34
Compiler: Visual C++ 1928 without C++ ABI

Build settings:
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
KICAD_SCRIPTING_ACTION_MENU=ON
KICAD_USE_OCC=ON
KICAD_SPICE=ON

Same type of behaviour. Concerning the turning off “optimize track being dragged”
sorry, where I can find it ? Nothing on Preferences …

Interactive Router Settings in the Route menu

Thanks @craftyjon, I turn off on Interactive router settings, for me no change. This should be probably solved latter.