ERC: Failed to read simulation model from fields KiCad V7.0.2

What happen to V7.0.2 ERC?

There is no error in V7.0.1 if I test it using ERC

How this error comes? Is this a bug or as designed?


I have the same problem

Nothing error if I test it using V 7.0.1

Were you able to solve it? I have run into the same issue:

My kicad version:
Application: KiCad x86_64 on x86_64
Version: 7.0.2-6a45011f42~172~ubuntu22.04.1, release build

Anyway, for the time being I simply clicked on “ignore all SPICE simulation related errors”

Yes, that’s simple solution.
But is the error set by default?
So we need to ignore it?

Yes; it’s a bug that will be fixed in 7.0.3 and you need to just ignore that error for now (or disable it in settings)


Maybe? But just as in your case, I did not have this issue with the previous version. Maybe they changed something in the newer version.

Ah, I see. Well, thanks for clarifying.

A bug reference: ERC: Failed to read simulation model from fields (#14562) · Issues · KiCad / KiCad Source Code / kicad · GitLab

Here are the steps to disable simulation errors in KiCad 7.0.2

  • Open your KiCad 7 project and select the “File” menu in the menu bar.
  • Select “Schematic Setup” from the drop-down menu to open the schematic settings window.
  • In the schematic settings window, select the “Electrical Rules” tab.
  • In the “Violation Severity” section, look for the “SPICE model issue” entry and select “Ignore” from the drop-down menu next to it.
  • Click “OK” to save the changes and close the schematic settings window.

Hi Mr. Jon Evans, when KiCad V7.0.3 will be released?
Thanks to KiCad developers

Hi @sarfat96

There will not be a 7.0.3. Please scroll to the bottom of this thread for an explanation.

I just got the same error:

I reverted to version 7.0.1 and I prefer to wait for the next updated version.


I have this same error running inside a Fedora rawhide official docker image (fedora:rawhide) (Inspect → Simulator → Simulation → Show SPICE Netlist). The error happens with Any BJT transistor, and the option to ignore SPICE errors is Already Marked.

Version Info:
Application: KiCad Schematic Editor x86_64 on x86_64

Version: 7.0.5-1.fc39, release build

wxWidgets 3.2.2
FreeType 2.13.0
HarfBuzz 7.3.0
FontConfig 2.14.2
libcurl/8.1.2 OpenSSL/3.0.8 zlib/1.2.13 brotli/1.0.9 libidn2/2.3.4 libpsl/0.21.2 (+libidn2/2.3.4) libssh/0.10.5/openssl/zlib nghttp2/1.53.0

Platform: Fedora release 39 (Rawhide), 64 bit, Little endian, wxGTK, , x11

Build Info:
Date: May 26 2023 00:00:00
wxWidgets: 3.2.2 (wchar_t,wx containers) GTK+ 3.24
Boost: 1.81.0
OCC: 7.6.3
Curl: 8.1.1
ngspice: 40
Compiler: GCC 13.1.1 with C++ ABI 1018

Build settings:

This problem seems to be library parsing and problems with libraries paths

Anyways, it don’t make sense to disable SPICE simulation if what you want is exactly that: TO simulate. Please stop asking people to do this.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.