Environment Variable can't be set to §{KIPRJMOD}

Hi,
if i want set the environment Variable “KICAD_SYMBOL_DIR” to “§{KIPRJMOD}”, the message “This path was defined externally to the running proces and will only be temporarily overwritten” appears. How can i resolve this problem? The environment variables are reset on restart of kicad.

KiCad version information? Help -> About -> Copy Version Info button, and paste here.

KIPRJMOD is pointing to the root of every project. KICAD_SYMBOL_DIR is generally assumed to point to the location of the system library. So if you point that variable to KIPRJMOD you would need to have the system library in every project. Are you sure you want to do that?

If you use this for your personal libs then my suggestion is to introduce your own path variable (example make one for USER_KICAD_SYMBOL_DIR and use this in the library table for your personal global libs)

If you want a project local setup then the better option would be to use KIPRJMOD in the library table. But here i advice against using it in the global lib table. My general suggestion is to use the project specific library table to define project local libs.

You might generally interested in this writeup Project and libary setup for sharing and collaboration (KiCad version 5) and also Library management in KiCad version 5

This error message also looks like at some point a system environment variable was set (and saved) for KICAD_SYMBOL_DIR. Possibly during a past install cycle. Without knowing what OS you are using, we have no way of knowing how to tell specifically you how to check to see if KiCAD variables were saved as system environment variables (instead of KiCAD environment variables).

Also, what locality are you using? I’m on En_US (and Win10) and all my variable substitutions start with a dollar sign ($), not a section mark (§)… I’m not sure if this is a typeo on your part, or if it is a locality difference (like, for example, US uses a period (.) for a decimal mark, other countries use a comma (,) for a decimal mark).

During a reinstallation (Windows 10) i let the “setting environment variables”-field unchecked. It’s now working.

1 Like