Either blurry or tiny icons on high DPI display - nightly build

I installed the latest version of the nightly build today, but when I first opened the program, the icons in Pcbnew and in Eeschema were blurry.

I can ‘mitigate’ this issue by unchecking the automatic icon scaling checkbox and setting the scaling to 100% manually:
But that makes the icons tiny:

I have attempted fiddling with the high DPI settings in Windows but they make the problem worse, no matter which combination of settings I use.

Scaling by system:

Scaling by system(enhanced):

Scaling by application:

No scaling override:

I’m running Windows 10, kicad build kicad-msvc.r24822.8e5cbc5cf0-x86_64-lite.exe, with a screen resolution of 1920x1080.

Application: KiCad (64-bit)

Version: (5.99.0-12964-g8e5cbc5cf0), release build

	wxWidgets 3.1.5
	libcurl/7.78.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 19043), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
	Date: Oct 26 2021 00:00:23
	wxWidgets: 3.1.5 (wchar_t,wx containers)
	Boost: 1.76.0
	OCC: 7.5.0
	Curl: 7.78.0-DEV
	ngspice: 35
	Compiler: Visual C++ 1929 without C++ ABI

Build settings:

Sorry for the excess of screenshots, I figure too many is better than too little :smiley:

I am grateful for any help at all!


PS I did search the forum beforehand, but couldn’t find any relevant threads.

1 Like

This is a known issue. We do not yet have a special HiDPI version of the icons, so they will be blurry if scaling is enabled.

1 Like

OK, thanks for confirming. I’ll manage with the tiny icons for now.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.